[Solved] I2S driver / Job Failed background worker is busy.


i’d like to build an audio network player with Raspberry PI / Sabre I2S DAC / Volumio.
Problem : i even can’t activate the generic I2S driver, the web interface says “Job Failed
background worker is busy”.
No audio output available in the player section.
Funny : even when i try to desactivate I2S driver, the background worker is still busy…
Could anyone help the newbie I am?



Same problem here with Raspi B+ / Hifiberry DAC (Jack ; 3.5mm) / Volumio 1.41

Thanks in advance,


Raspi B+ HifBerry Digi Dac I have the same message when trying to apply any settings on that page i have researched briefly and found others are having the same issue but i can find no solution as yet :cry:

Any help gratefully appreciated

running 1.41 b+ and hifiberry digi and got exact same problem :confused:

here’s a turnaround to install the hifiberry B+ worth checking


Thanks sublimusic for information. It will probably be very useful for B+ owners.

But my configuration is Raspbery PI B / I2S DAC (ES9023) / volumio 1.4

I can’t activate the RPI I2S generic driver, whether the DAC is plugged on the P5 GPIO, whether it is not plugged.

Many thanks for your help!

I got the same message with my HiFiBerry Digi. I just rebooted the Pi and all was good.


thanks for your answer. Unfortunately, reboot, reflashing the SD card… does not work.

maybe a faulty PI…

Hi guys and thanks “sublimusic” for the link you provided i followed that and the info from Plasma25 and my B+ and Hifiberry dac digi is working and currently playing radio paradise as i type this it still says background worker is busy when i click on the tab for the selection of the Dac but it’s working and sounding fine :smiley: :smiley:

Best Regards

This solution works with Volumio 1.41, maybe on both models (b and b+).
I tested it only with b:

  1. Don’t upgrade your Linux kernel!

  2. Add the following lines to the file: /etc/modules

Hifiberry DAC

snd_soc_bcm2708 bcm2708_dmaengine snd_soc_pcm5102a snd_soc_hifiberry_dac

Hifiberry DAC+

snd_soc_bcm2708 bcm2708_dmaengine snd_soc_hifiberry_dacplus

Digi and Digi+

snd_soc_bcm2708 bcm2708_dmaengine snd_soc_hifiberry_digi


snd_soc_bcm2708 bcm2708_dmaengine snd_soc_hifiberry_amp

  1. Create or, if exist, edit: /etc/asound.conf with the following content

pcm.!default { type hw card 0 } ctl.!default { type hw card 0 }

  1. After reboot system you can choose the Audio Output (sndrpihifiberry) at the playback panel on the web interface.
    Apply the settings and mpd will restart.

Now my hifiberry is working without problems. :smiley:

The kernel of Volumio 1.41 does not contain the hifiberry_dacplus driver, so I don’t think this would work.

Hello Volumio People - noob first post here.

I’ve recently bought a raspberry pi and am running volumio, it runs great. I’ve added the hifiberry dac but i’m getting the background worker is busy message. So I have to add the above lines to the /etc/modules. Excuse my ignorance but i am a complete noob on programming. How exactly do I edit this file? I’ve got a puTTy screen open that I’ve logged into as root then volumio as the password.

This is the prompt I have:


I’ve tried entering the text shown for the hifiberry dac but all I get is “command not found” messages.

What exactly do I type in on the puTTy screen?

Thanks in advance.

Got it working by upgrading to the 1.5 software. No more background worker is busy. Now enjoying fantastic HQ gapless playback!
Fantastic product Volumio, thanks very much :slight_smile: