[solved for now] MPD crashes with ESI Dac 16/44

Hello, first post here…

Volumio seems to have trouble running stable with one of my two dacs i am using.

Running i86 selfbuild htpc with more then enough specs.
Latest Volumio build.

With RME ADI-2 Dac everything runs fine without any troubles.
But when i switch to ESI Gigaport HD+ the trouble begin.
I am using Linn Kazoo controlpoint, which works fine with the RME ADI-2 Dac and also when running BubbleUpNp server for intergrating Qobuz.

When using the ESI Gigaport HD+ dac, MPD crashes when adding an album or song.
Sometimes it plays an album correctly, usually after rebooting Volumio, but it still crashes when i add songs or skip to next track.

Here is the log i made (to keep it small, i rebooted Volumio and tried to play an album in Linn Kazoo app)

I’m no expert in reading this log, but i’m sure there are things that aint right.
It seems related to upmpdcli, that’s all i can see.

Help appreciated.

By the way: When using the web-ui or Volumio app, things run more stable, but still issues when switching or adding songs.
The playlist in web-ui and Volumio app do not update and don’t reflect the playlist in Linn Kazoo.

Try this dev image first, it has a much newer kernel and could make a difference regarding the usb audio driver and supported DACs.


Thanks will try that.
Strange that an older dev version contains newer kernel?

Will report back with my findings

Crashes after 3-4 seconds


well, at least that eliminates usb audio issues from possible causes.
Does this happen on all usb ports? Do you have the possibility to use an external psu to power the DAC?

Haven’t tried other USB ports, will try later.

It can’t be a psu problem.
htpc is build for very low power consumption:
Case: Streacom F1CWS Evo
PSU: Streacom Nano160 fanless power supply
Motherboard: Gigabyte GA-N3050N-D3H
RAM: 2 x Kingston ValueRAM 4GB 1600MHz SO-DIMM Low voltage 3L Version
SSD: 80GB Intel 320

Different USB port works better, I can actually play some songs and albums and mpd doesn’t crash when selecting a new song. Now, will different USB port also work with latest build; MyVolumio?

The web-ui and Volumio app don’t reflect/update when using Kazoo (working as intended?)

Hmmm cheered to early, crashed again and not loading a new album anymore…

could be a power issue, therefore my question for the DAC. Is it or can it be powered externally, not from the usb port?

Unfortunately it can’t be powered externally

GIGAPORT HD+ is not like any other USB audio interface … it’s simply the multichannel playback solution with the best price value ratio on the market due to its unique set of features providing 8 independent outputs (and full 7.1 surround sound support), 2 independent stereo headphone outputs and excellent audio quality supporting up to 24-bit and 96 kHz.

GIGAPORT HD+ provides ASIO 2.0 drivers for professional audio mixing and playback under Windows XP and Windows Vista / 7 / 8.1 / 10 (both 32-bit and 64-bit). The hardware is also CoreAudio compatible and nativly works under Mac OS X even without the installation of a special driver.

This makes GIGAPORT HD+ perfect for digital DJs on the road working with notebook computers. Simply use your favorite DJ software and GIGAPORT HD+'s eight outputs as up to 4 different stereo channels, enabling you to mix, cue and add effects! Monitor and pre-listen to your signals via the two built-in headphone outputs. GIGAPORT HD+ of course also works on your desktop computer and is compatible with all important professional audio software applications like Cubase, Sonar or Logic. The hardware also works with consumer programs such as DVD playback software.

24-bit / 96kHz D/A converter
8 independent output channels with RCA connectors
different playback modes: 44.1kHz with 16-bit and 8 channels, 44.1kHz with 24-bit and 6 channels, 48kHz with 24-bit and 6 channels, 96kHz with 24-bit and 2 channels
2 independent stereo headphone outputs: 1st output sends out mixed signal of all playback channels, 2nd output sends out different signal from playback channel 1/2 - perfect for monitoring and to pre-listen to signals
compatible with Windows XP and Windows Vista/7/8/8.1/10 supporting ASIO 2.0, WDM, MME (using ESI’s EWDM driver technology)
compatible with Mac OS X and supported by the native CoreAudio USB audio support from Apple, no special driver installation required
compact and portable design with around 12 cm x 7 cm x 2 cm


Tried a different cable, no succes

To make sure the device ain’t defective, I ran it on my laptop and I can play everything just fine without any problems.

Alright a few weeks of experimenting and sofar still not able to get things run stable.

I found out something yesterday evening, strange i didn’t notice before:
It seems that all my 24 bit music plays perfect and the problems of MPD crashing is only with 16 bit music.

When i connect my laptop to the ESI DAC, i can play all my music, no matter the bitrate.

Any ideas why MPD crashes with normal red book cd rips and plays 24 bit HR just fine?

Sofar i tried different volumio builds, different upmpdcli versions and different MPD versions.
The problem of MPD crashing with 16/44 files is among all, while 24 bit music plays excellent.

Can anyone explain why all 24 bit music plays perfect (local NAS and Qobuz) and every “ normal” 16/44 crashes MPD or UPMPDCLI
Why is this possible?
One would think it would be the other way around…

Well, discovered something that might help to get a solution.

I’ve added a network drive (NAS) into volumio-ui.
It scanned for music and added those to music library (volumio-ui).
I can play everything form this library, including 16/44 flac ripped cd’s.

But when i go try to play music from “mediaservers” (tried minimserver and minidlna, same result) only 24 bits music plays; 16 bits fails and crashes mpd.

My brain is overheating, i cannot think of anything what might cause this…

Qobuz in MyVolumio acts the same as described above.
Using web-ui, 16/44 music crashes and 24/* plays fine

Manual installing MPD to 0.20.23 solved it somehow…