[SOLVED] DLNA renderer not visible via Wifi - Rpi3

I have an RPi 3b with Allo DigiOne card, running Volumio 2.692. I am having trouble using it as a DLNA renderer when connected by WiFi.

If connected by Ethernet, Volumio is visible as a DLNA renderer on my home network. If connected by WiFi, it usually is not visible. If I run the config wizard, it becomes visible until I close the DLNA control point (BubbleUPnP), then is not visible when I reopen it.

It is always possible to use the Web interface, but I prefer to use it for DLNA through a control point.

Is there a solution to this that I can apply through the Web interface (without connecting monitor and keyboard)? I find mentions of this problem from as long as 5 years ago, but the answers all seem complicated to me, as they use a command prompt, with no instruction of how to open one. I am not averse to entering commands, but I have no idea how to go about it with this headless box.

Or is this still an unsolved problem? If that is the case, is there another headless OS that I could try?

I should add that I have refrained from trying the solutions posted 5 yr ago also because Volumio has changed in the interim, and I’m not certain that they are valid. Many refer to settings that are no longer available in Volumio (like the toggle for DLNA).

I may have solved this problem. At least, it works now and has survived several reboots.

In my ASUS RT-AC88U router, I went to Advanced Settings > Wireless > Professional and made this change:

 [b]Enable IGMP Snooping[/b] from Disable to Enable

The Volumio/RPi3 DLNA renderer is now visible on my home network.

I looked at multicast settings after reading an old post that found disabled multicast was a culprit in this issue. Though mine didn’t seem (to this novice) to be disabled, clearly it needed better configuration.