[Solved] Database Updating forever

I recently completed the volumio setup using v 1.2 beta downloaded from sourceforge and now the DAC is OK.
The thing that is still annoying me is that the database goes updating forever. I tried to connect an external USB disk with my music archive, same story. Then I tried a remote shared folder with samba, same thing, the database results incomplete and goes updating endlessly.
Other things I don’t like:
the folder are shown with no order and so the songs in the folders.
If I try to add a new mount with NFS as fileshare protocol I get an error page

Can anybody help on these?

Thank you,

Hi, I find that modifying the mpd.conf adding

decoder {
plugin “ffmpeg”
enabled “no”

solves the database issue


I’ve got the same problem you’ve described in the first post.
I’ve tried to edit mdp.conf as you’ve suggested but there’s no way to get it fixed.
Anybody knows how to fix it?
Thanks in advance.

This solved my issue, although I don’t understand why.

Would someone care to explain? Did I remove the ability for the database update engine to try to decode the music and thus removed any possibility that it might fail and block everything?

Kind regards.

isnt ffmpg required if you are looking to plat apple lossless files?
see: how-to-configure-ffmpeg-support-m4a-aac-files-t626.html


I have also the problem mentioned above. I also do not see my NAS HD active after while, although in the volumio webGUI it is still updating. /var/log/mpd/mpd.log tells me after adding the last song, which I also see in the webGUI:

[parse.c:1078] error: Giving up searching valid MPEG header after 65536 bytes of junk.

Is this ffmpeg option already set to false in the recent version? I am using 1.41
After a web search I find a posting of michelangelo saying that he wants to deactivate this in future versions by default.


In the mpd.conf I found ffmpeg plugin enable “yes”.
After starting building the database from scratch for the fourth time, I thought I have nothing to loose and set this manually to “no”. Unfortunately, volumio did not continue building the database. Now, it started to run for the fifth time. Hope it works now.


Note: Illegal Audio-MPEG-Header 0x00000000 at offset 4092.
Note: Trying to resync…
Note: Hit end of (available) data during resync.
Oct 23 22:05 : mpg123: mpg123_getformat() failed: Message: I am done with this track.

Sorry, I am just posting unusual stuff from the mpd.log, if you do not mind. Maybe someone has a solution.


I have had the same issue and solved it by changing the configuration file (“no” instead of “yes” for FFMPEG).

I thought the new version 1.5 would enable deactivating ffmpeg through the settings ? Is that still planned or is there an alternative solution ?

How long does the first Database Update (to connect with a UPnP Server) take? Mine is running since 8 hours and i start to worry that theres maybe something wrong…

It just needs to add 200 GB of CD Quality flac files…

im using Volumio 1.5 on i Cubox i4.


Any chance of deactivating ffmpeg through the web-browser in the coming version ?