[Solved] DAC no longer recognised (Schiit Modi mkI)

Hi all,

Strange behaviour: out of nothing my R-Pi 3 won’t recognise my Schiit Modi mkI DAC anymore… I recently updated to Volumio 2.413 and that worked fine for several weeks so I don’t expect any issues there.

It started last week, when I had to reset the internet and wifi. Volumio automatically reconnected to wifi, but when I accessed it, it had lost connection to the DAC (“Failed to open alsa device”). Several reboots with plugging and unplugging the DAC later, still no luck, until I did a Factory Reset on the system. There it was again.
Few days later I shut down the Pi (as precaution before I reset the router), and again when I started the Pi the DAC was gone. Since then, I cannot get the DAC to be recognised. I did a Factory Reset again, and when that didn’t work a full fresh install of Volumio.

The DAC has power, but is not recognised whatsoever in Volumio, on none of the USB ports. The output of “lsusb”:

sudo lsusb Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. Bus 001 Device 001: ID 1d6d:0002 Linux Foundation 2.0 root hub

On my Windows laptop the DAC is recognised straight away. Interestingly I’ve had a similar issue with my Zero W, which was unresolved until I finally decided for a Pi3 with stronger power supply.

Any idea what is going on? The DAC should be one of the easiest, since it’s driverless and has worked already since Raspify…

Thanks in advance for the help!

I have done some digging into this and found a similar problem from a RuneAudio user. I submitted my logs so I could search them too: logs.volumio.org/volumio/wJmebPQ.html

Funny enough, I see exactly the same error lines in the log, that it cannot detect the Schiit. Especially the “Under-voltage detected!” might indicate that this is a power issue after all. But when I encountered this issue with my Pi Zero W, I built a Y-cable to split the signal and power of the DAC. That didn’t help, that’s why I ended up buying an R-Pi 3. I will try once more with this cable, to see if it pops up again in the logs.

Jun 20 23:30:10 volumio kernel: usb 1-1-port3: Cannot enable. Maybe the USB cable is bad? Jun 20 23:30:10 volumio kernel: Under-voltage detected! (0x00050005) Jun 20 23:30:10 volumio kernel: usb 1-1-port3: Cannot enable. Maybe the USB cable is bad? Jun 20 23:30:10 volumio kernel: usb 1-1-port3: attempt power cycle Jun 20 23:30:10 volumio kernel: usb 1-1-port3: Cannot enable. Maybe the USB cable is bad? Jun 20 23:30:10 volumio kernel: usb 1-1-port3: Cannot enable. Maybe the USB cable is bad? Jun 20 23:30:10 volumio kernel: usb 1-1-port3: unable to enumerate USB device Jun 20 23:30:10 volumio kernel: Voltage normalised (0x00000000)

Do you happen to have a PI 3B+?

Lately we’re seeing a lot of issues with USB popping out all over the place

No, it’s a regular model 3B. And it also happened with my Zero W before. I checked and they don’t have the same SoC, so I don’t think that is the problem.
Let’s see if my power split cable works again.

I found two other old topics on this issue: problem-with-shiit-dac-modi-usb-port2-cannot-enable-t3264.html

As suggested there I added “dwc_otg.speed=1” to boot/cmdline.txt. Surprise, and after a reboot Schiit showed up as device again. Though in dmesg it mentions for all the usb devices that it should be connected to a high-speed port for better performance.
I removed the “dwc_otg.speed=1” again, rebooted, and the Schiit was still there. I don’t dare leaving it at the slow speed after Michelangelo’s comment “Just don’t expect to get your FLAC files from NAS…” - which is exactly what I do over the built-in wifi!

Online I have found more stories of people experiencing similar issues with the Schiit Modi on Windows laptops, where an external power supply did not necessarily solve it. Good thing it’s not R-Pi/Volumio specific, just a bummer that there does not seem to be a solution to it.

Oh my, I feel absolutely stupid now. :unamused: :blush:

After all the hassle with the power split cable, I jokingly switched back to an old usb cable that I used with the DAC before for quite some time. The Schiit was recognised right away again and is playing happily for several reboots already.

The error messages even said so. :unamused:

Jun 20 23:30:10 volumio kernel: usb 1-1-port3: Cannot enable. Maybe the USB cable is bad?

:exclamation: Bump

This problem is back again. I had to reconnect the setup this weekend, and again the DAC is not recognised after booting.
Several reboots and factory resets later (including the appropriate waiting time), and it simply won’t recognise it. I tried two different cables, externally powered hub, all four USB-ports, nothing. Once, the DAC was recognised but after a reboot it was gone again. The DAC still works plug 'n play on two laptops.

It seems to be really a Pi or Pi-DAC-combination problem. Upon boot, even when the DAC is powered through a hub, I can see that the Pi power-cycles the DAC one or multiple times. In the logs it also shows that it power-cycled the device and eventually comes with the same “bad cable”-error.
On the laptops I noticed that the DAC sometimes takes a few seconds to be recognised. Could it be that the Pi is simply too impatient with power cycling? Can I add a 10 second or so delay upon boot? (and where should I add that…?)

I double-checked the logs today. Along with the Cannot Enable Device, it advises to add “bootdelay=5” to the boot command line. I checked, but this was already in the boot command line. I changed it to 10, no result.
I also wanted to see the log when booting with external power. Same errors pop up in the log (see logs.volumio.org/volumio/UBbwldn.html)

By now it’s slowly driving me mad… No apparent reason why it does not recognise the DAC. Other that I’m unlucky with my Pi maybe? :neutral_face:

Finally, after an evening of testing with an R-Pi 3 and R-Pi Zero W, Volumio and Raspbian sd cards, and a powered hub, this issue seems solved.
The answer for the Schiit Modi gen 1 on R-Pi 3 is to force usb 1.1 mode by adding to /boot/cmdline.txt:


On a Ubuntu Live and Linux Mint, the Modi would be recognised no problems. With Raspbian on the Pi Zero W, and the powered hub, also no problems.
However with Raspbian on the Pi 3, like with Volumio, the DAC was simply not detected, despite the powered hub. The same error message appeared in the logs: “Cannot enumerate device”. Having a compatible, powered hub, this ruled out any power issues.
Diving further into this error, I found a possible solution for older devices to force usb 1.1 mode. I recalled that the Modi gen 1 is designed to work plug 'n play and is therefore usb 1.1 compatible.
After modifying the cmdline.txt to force usb 1.1, the Pi 3 could detect the Modi reboot after reboot, with and without the powered hub. Fresh install of Volumio 2.502, added this line as well, and this also holds for several reboots already - without the usb hub! I just hope this sticks after updates.

It seems that the LAN9514-chip of the R-Pi has compability issues with older devices on the newer Debian/Raspbian versions. Schiit itself does not have a firmware update for this, unfortunately.

I know this thread is two years old but how did you get it to work, I have a schiit modi 1 can’t seem to make it work on the raspberry pi 4 no matter what I don’t think im enforcing the USB 1.1 properly