[SOLVED] Cubox - Error

Thanks !
If you want, i can do some test.

I tried this dev version: No image in screen, impossible to login via SSH

Hey ths, thanks for reporting this.

I also tried the image that is referenced above with the same result. As far as I can tell, this is still the same image, that I had already tested and reported on here: https://volumio.org/forum/volumio-for-cubox-coming-t4580-50.html The links in both tickets point to the same file. Unfortunately something seems to be broken :frowning: .

Generating a dev image while writing this.
I will let you know here when it has been placed on http://oph.mdrjr.net/gkkpch for testing.
(2-3 hours after posting this)

– Gé –

Unfortunately this is not going to work, the image build seems to be broken at the moment.
I’ll check this with @michelangelo.

Hi Ge

Could you please include the kernel headers in the next build?

OK, you will find a dev version on http://oph.mdrjr.net/gkkpch/, look for “Volumio-devhdr-2017-03-03-cuboxi.img.zip”
Note: this version will only be online for approx. 1 week
Feedback is very welcome, an official version will be published afterwards.

@flahutbux: our build script has been updated, header files are now to be found in “/usr/include”

Known issues: Using built-in wifi with hotspot or ethernet with Volumio UI: you will need to manually add your wireless router.
Due to limitations of the wireless driver.

Hi Gé,

Thanks for your work on this. Very grateful. :smiley:

So far everything is working, havent’t found any issues, apart from ones that are already known or which I had seen reported in other posts.

Tested with wireless (no LAN connected after setup), FLAC (single-song) on Synology NFS-Share, Airplay, MP3-Radio Streams, Spotify-Plugin, Spotify Connect2-Plugin. No dropouts or any other problems.

System: Cubox-I2ex with USB DAC (QNKTC)

I will drop a note should anything pop up.

Greetings / Christian

EDIT: just a side-note - LAN was only plugged in during initial setup. After LAN-disconnect and sole use of wireless, ‘volumio’ could not be reached at that hostname anymore. On my DNS (=router) I had to delete the DHCP information/lease for the LAN port of my device as the router still kept resolving the ‘volumio’ address to the then disconnected IP of Cubox LAN (even after re-boot).

Hi Ge

First of, thank for the new test image.
So far, all good:
nfs mount OK
scan library without issues (no error, no freeze)
webardio OK.

But I do not manage to compile drivers for a wifi dongle.
I have the following error:

Looking a bit further, /lib/modules/3.14.79/build is linked to /home/cubox/linux-fslc.
link seems to be broken.
I may be wrong or most likely not skilled enough to fix this issue.
Any advice?


Hi Gé,

Guess I found something: UPNP doesn’t seem to be working as it used to on 2.029.

The Volumio UPNP-Renderer is not visible on the network anymore (i.e. BubbleUPnP on Android). Tried LAN/WLAN and both connected exclusively; no luck. I could not locate any related reports in the forum, so maybe this is a Cubox-only problem?

Can someone please confirm if working / not working for them? Is there anything else I should try with this?

Thank you!

Hi Ge
As far as I m concerned, it s a stable version.
One point to be noted though: the last track in the queue is always played twice, which did not happen on previous versions

Thanks for reporting, the track issue counts for all platforms, there may already be a newer version not having it.
You may want to try version 2.129 from March 26th.

The library issue has been resolved, a big thank you to the people who helped testing/ verifying.
We will be releasing new images the next few days :smiley:

– Gé –

Hi Gé

Just tried the new version. Update mechanism worked fine.
Great job.
Noticed two issues though:

  • The consume playlist function does not work for me
  • The queue seems to be automatically on repeat

Can t find a way to change that behaviour.
You may want to look into that before the next release.


PS: for the kernel-headers, I noticed they are available as a tarball, but I can t find a way to use them.
If you have few hints, I would appreciate; best would be to have the package itself (at least for me and my limited linux knowledge)

Just unpack the tarball from where it is. Your headers will then be in the same place as if you installed the debian header package yourself.

As for the other issues, these are not cubox-specific, you would need to open a separate topic for it.
I’m closing this topic because it is too general.