[Solved] Can not flash SDcard in linux

I am unable to reinstall Volumio on my flash card. Last time I installed was in windows.

I have tried DD method described… Not working.
I have tried unetbootin… Not working.
I also tried restore image with gnome-desk-utility… Not working.

None of these option works. Rasbperry wont even boot or read card.

please help! :frowning:

You must be root to do this. :wink:

I am root. :smiley:

Can you describe the steps you perform in order to write the SD-card?

I usually do:

  • sudo su
  • put the SD-card in the linux-PC
  • check if the card is automatically mounted with “df”, check for entries like /dev/mmcblk0p1, /dev/mmcblk0p2
    • if mounted, unmount the the SD-card (e.g. umount /dev/mmcblk0p1; umount /dev/mmcblk0p2)
    • if not mounted check with “lsblk” you should see the SD-card (mmcblk0) - if you cannot see the SD-card reinsert it and check again
  • unzip the Volumio-image (unzip /path-to-mig-file/Volumio1.55PI.img.zip)
  • write SD-card (dd if=//Volumio1.55PI.img of=/dev/mmcblk0 bs=4M)
  • sync data to SD-card (sync;sync)
  • remove the SD0card and insert in the PI

this is usually enough to use the card to boot your PI with Volumio.

thanks for this. I did it previously in a similar way. I followed these steps. I also tested 3 differend sdcards to rule out card failure

Im running linux mint cinnamon 17.1

I redownloaded the image file as torrent, just in case and unzipped with root
The image is sucessfully written but none of the sdcards are still bootable. When i put the sdcards back in the PC Gparted says Unrecognized device. Something is wrong here, I dont even think boot partition is readable. Should i format the sdcard in some way before i write image? I usually clean up the unkown device and make a new partition table from scratch with gparted just to make sure that the disc is clean. Oh wait a minute… This is where I am doing it wrong. I actually create a new partition with gparted before writing image… I think I figured it out now! :smiley: I was overdoing it! Thanks for your reply!

I just formated the SDcard with gparted. Left the sdcard unformated. Then ran

sudo su
dd if=Volumio1.55PI.img of=/dev/sde bs=4M;sync;sync

Glad to hear that you’ve solved it !! :smiley: