[Solved] BubbleUPnp on Nexus 7 - No library for Volumio

I am new to volumio, network based music systems, and linux. I think that is the long way of saying Noob. I am having a problem that I hope others might be able to help me with. I am trying to control a raspberrypi/volumio setup with a Nexus 7. The volumio web app sort of works, but I need a bluetooth mouse to select music and sometimes, the web control app crashes when loading the library. I am now trying to use BubbleUpnp as a controller hoping that it might work a bit better on the Nexus. The issue I am having is that if I select Debian:root as the library for BubbleUPnp,none of my music shows up.

Here is my setup:

Rpi B, Volumio 1.4 with an update (apt-get update, dist-upgrade). When updating, there is a question regarding the replacement of /etc/php5/fpm/pool.d/www.conf. I have tried both options, update and retain, both of which act the same with respect to my problem. The pi is connected to the lan with an ethernet cable. UPNP control is turned on, Airplay is turned on. I have tried UPNP\DLNA Indexing both on and off with no change in results.

Nexus 7
2012version 32GB Android 4.4.4 Using wi-fi for connection to lan

Current music library
is an itunes library stored on a western digital Mybooklive NAS in the Public share, which is set for media streaming. THere are about 440 albums/5200 songs. The file format is .m4a. The NAS is connected to the lan by an ethernet cable.

Here’s what I’ve found so far:
Web app running on Nexus plays music on rpi/volumio with issues mentioned above.

BubbleUPnp shows the following rederers:
Local Renderer (the Nexus 7)

BubbleUPnp shows the following libraries:
Local Media Server
MyBookLive (my NAS)
demo internet libraries supplied by BubbleUPnp if I add them. MediaTomb and MinimServer

Here are the results of some renderer/libary combinations (after mpd update to insure correctness):

Renderer: Volumio
-------------Volumio:root: No library choices are displayed to choose from, though I do get folders showing things like artists, genres, music.
-------------Local Media Server: Works - I hear music on rpi
-------------MyBookLive: Can see music in library, but will not play on rpi/volumio. The BubbleUPnp “Now Playing” window shows the run/pause icon alternating between > and ||.
-------------demo internet: Works - music on rpi

Renderer: Local Renderer
------------Volumio:root: No library choices are displayed to choose from, though I do get folders showing things like artists, genres, music.
------------Local Media Server Works - I hear music on the Nexus
------------MyBookLive: Works - music on Nexus
------------demo internet: Works - music on Nexus

Not sure where to continue. Any ideas will be greatly appreciated. Thanks to all those that have contributed to the various projects that makes all this possible.

Tom Harper

Are you running a media server on your NAS (twonky or similar) ? Have you tried setting up a test library that is mp3 / flac separate to the itunes library on the NAS to see if that works better with bubble upnp?

The WesternDigital MyBookLive NAS allows a share to be set as a media server, but I will look into that further to see exactly what it means. I don’t know what the various standards might be, so perhaps setting up something else will help. It seems to be acting as some sort of media server since I can select it as the library and play the tunes on my Nexus. I need to learn more about the overall “pipeline” that gets the bits from the NAS to the DAC.

I have just copied some MP3 files to another share and will see what success that has. I’ll have to do a mpd update which will take a while, but once I run the test, I’ll report back.

THanks for the ideas,


I can confirm that you can playback m4a on Volumio RPI Renderer. I did this with Synology NAS, Nexus 7(BubbleUpnp) and Volumio/RPI+DAC.

Ian’s advice is heading in the right direction, create a Media Server share with a few different files (m4a, mp3, flac, etc.). Read your NAS manual and make sure you are using a DNLA compatible Server (not the iTunes Server).

The best pipeline/audio path that you can have in your set up is:-

  • DNLA Music Server broadcast by NAS, Master Library stored and Server broadcast from NAS.
  • Nexus7 & Bubble :- use as control point e.g.
    - select source/library (NAS Music Server)
    - select sink/output (Volumio DNLA Renderer)
    - Control Playback (selection, start, stop, queue etc.) from Nexus 7.
    -Volumio as DNLA Music Renderer.

Anything else is a compromise so you should concentrate on getting this working. It Should :confused:

Hope this helps


The MyBookLive used to use Twonky, but now uses Western Digital DLNA, which I have read is a version of minidlna. The DLNA server is enabled, as is iTunes because I am still using iTunes on my desktop.

I created another share that has only MP3 files. Sure enough, renderer=Volumio, library = NAS plays them on the raspberrypi setup. The library displayed also includes the iTunes library from the other share, which are the m4a files. If I choose one of them with the same setup, they do not play on the raspberrypi. If I change to the local renderer, they do play.

I’ll continue to look into this and see what I can figure out. In the meantime, x7dude posted a modification that allows the volumio web app to load the library in segments based on artist choice which makes it faster and easier for me to use, so I am using that while I work on this issue some more. See Guides/Make the Library Load Faster. It’s good to know that NWTStuff is getting music from this config. I think I’ll turn off the itunes server on my nas and see if that makes a difference. Thanks again for the help.

Hmm a bit weird. I would suspect the Bubble,nexus,nas side of things; but this is only a guess :unamused:

Can you confirm that you’re volumio build will play m4a. You can do this by copying a couple of m4a files to a usb drive or the sd card. Then try to playback using volumio UI. Worth a try maybe to rule out volumio as the issue.

I’m just wondering about the m4a files now. Are they downloaded from itunes ? Is there some protection here that might affect playback ?

I can see and play the entire library when I use the volumio-provided web user interface. The m4a files are a mix of music bought from Apple and CDs of mine that I ripped via iTunes running on my desktop.

Here is a quick summary of what I can play when I set the library to the MyBookLive NAS:
I can play all of the music (MP3, m4a) in the library using bubbleUPnP when I set the renderer to be the Nexus.
I can play only the MP3’s using BubbleUpnP when I set the renderer to Volumio (the raspberrypi/Volumio)

Disabling the iTUnes server running on the NAS had no effect on trying to use the volumio as renderer and NAS as library. Once again, MP3 files play, m4a’s don’t. I selected an m4a that was from one of my cd’s rather than a download from Apple. There was one change though. THe library volumio:root is now gone from the list of available libraries in BubbleUPnp. I re-enabled iTUnes server on the NAS, exited BubbleUPnp, emptied it’s cache and cleared its data, but I still do not get voluio:root in the list of libraries. There may be a clue lurking there that I will try to find.

I’ll try some more things in a bit. Thanks for more ideas.


ITunes is pretty agressive in what it does to files when they are encoded for it’s library both in terms of tagging and art and format. This applies to both ripped CD’s and downloaded tracks. Apple users like consistancy. If you put a non iTunes encoided track into iTunes it often forgets or deletes it from the library if the tagging is not consistant with iTunes standards.

Android (on your nexus) will play pretty much anything, especially m4a as that is part of the mpeg suite and is used as the audio container for mp4 video files. Google have been working on android for years and it’s easy to get unrecognised formats to play simply by downloading another player which then populates android with the requisite codecs. So bubble upnp will use the native renderer/codec in your tablet to play the file.

Volumio is a very specific music device that is quite happy with mp3 and flac but might struggle with m4a and other formats. As Kevin suggests putting an m4a onto a usb stick or on the SD card will confirm wether the issue is with volumio or on the upnp/NAS side.


I think the effect of losing the volumio root in Bubble is a coincidence and a bit of a red herring. In any case I don’t think Volumio will act as a proper DLNA server. In this case you are trying to stream from a NAS mount on the RPi to the RPi (which makes no sense to me as we stream from one device to another).

Try to use the web interface or try the Android App “MPD Droid”. This will connect directly to the Volumio device.

Maybe try using another Streaming app and see if you get the same results. Try using “Skifta” and see if you get the same problem.

Do you have a PC or MAC ? If so what OS ? This might help with future tests if we can’t figure it out.

My money’s on the DNLA Server of the WD NAS but that’s only a wild guess and cos I am a betting man :laughing:

Good Luck, Kevin

To enable volumio’s built in DLNA/UPnp server you need to edit the file /etc/minidlna.conf

find the line that looks like this: #media_dir=/var/lib/mpd/music

and delete the hashtag so it looks like this: media_dir=/var/lib/mpd/music

and off you go a streamin’.

(not sure why that wasn’t enabled by default)