[SOLVED] 5102 DAC error-Failed to open ALSA device

I’m trying out a newly received inexpensive Chinese DAC (purple board) with a 5102 chip.
I have connected it as follows to the Raspberry Pi 3:

SCK J8-39 Ground
BCK J8-12 (audio data bit clock input to 5102)
DIN J8-40 (audio data input to 5102)
LRCK J8-35 (audio data word clock input to 5102)
GND J8-6 Ground
VIN J8-2 +5v

This wiring was used by two others with success according to their posts.
Here masterandrey.com/posts/en/dac_ra … i_pcm5102/
and here

I have tried several DAC models in “playback options”: Generic I2S DAC, HifiBerry DAC, HifiBerry DAC+ and had the same result each time.
When I play audio in volumio, the result is Failed to open ALSA device “hw:1,0”: No such file or directory.

I saw some discussion of this error in an earlier release but I am a relative newby to this process and do not see that it applies here.

I would appreciate assistance in getting this DAC working with volumio.

A pcm5102 does not need anything specific, so “Generic I2S DAC” or “HifiBerry DAC” should have been giving some sort of sound.
Leaves the wiring to be double-checked, can you please post a close-up picture of your DAC and its pins?

Thanks, gkkpch, just after I posted that, I reseated the wires again and restarted on HifiBerry DAC again, and it started to play correctly.
(I would have modded/deleted the post but I didn’t know how soon it would be “posted” by the admin review.;^)

I will have to solidify this test setup since the error recurred after I tested the ALSA equalizer and then deactivated it again. It appeared that error immediately disappeared when I restarted volumio, so not sure if it was an effect of switching on/off that plugin, or the “shakey” wiring again.

Sounds great when its playing.
Thanks again.

something in your opening post must have triggered an admin review, this normally does not happen.
No worries about the post, no need to modify or delete. I labeled it “solved”.