[SOLVED] 2.344 crashing Odroid C1+

Hi all,

I have a similar problem like the one that arrived to bikutoru on his RPI3.

On a fresh new install on Odroid C1+, Volumio crash after a some minutes and then going bootloop :
Web GUI crash (spinning wheel) and freeze. Track continue to play normally but playlist is broken. After few seconds, volumio reboots (spinning wheel and startup music can be hear), then bootloop crash every 30’’/1’.

I sent log but can’t get the logs…. because the /dev screen still indicates “sending log reports, please wait” but nothing happen :confused:

I have 3 plugins installed : spotify, youtube and Backup & Restore Data

Here is the log :


Thanks, since I can’t replicate your issue on my system, it would be really helpful if you could help me understand where the problem is. IMHO this issue is due to the new DLNA plugin.

1- Which DLNA\UPNP server do you have on your network?
2- Can you please connect via SSH and do

volumio pull

(this will update your volumio instance to the latest code, including the fixes I’ve done today).
Does the problem still happen?

Thanks a lot if you will help

ssh connect to host port 22 : Connection refused.

I have no DLNA/UPNP server.

Before using 2.344, I was using 2.317 from gkkpch and everything went fine

EDIT : Sorry. Forgot to enable SSH via /dev…

Volumio pull doesn’t seem to resolve the problem. GUI crash after few seconds on first track.

Here is the log : logs.volumio.org/volumio/YIMaxhu.html

If I scan Network drives from My Music, it shows my personnal laptop (hp zbook windows) and my internet box (freebox revolution with a hard drive but I don’t use that drive). And none of those drives is mounted.

First question: which device has the ip ?
Are you able to tell me which service runs on ?

(I ask so if it’s something I can install, I will be able to fix the issue).

Then, could you please do:

nano +246 /volumio/node_modules/node-ssdp/lib/index.js

and change

throw e to



killall node

Thanks, that’s very important…

This is my personnal laptop I use to access to volumio (via Firefox quantum 57.0.2 web browser)

Sorry not today. No service use the PID 2869.

Without restarting volumio, crash as describe in first post. Album queued. First track play normally. GUI crash. Track continue to play but when it finished, the queue doesn’t continue to play.
Restarting volumio, same problem.

here is the log : logs.volumio.org/volumio/HywU8A0.html

I just solved the issue.
I would be glad if you could confirm it.
Just do:

volumio pull

and let me know

Looking at the above log :

Dec 19 18:26:55 volumio volumio[839]: Error: connect ETIMEDOUT is my laptop but under the windows task manager, I don’t see service/process using the PID 2869. Maybe I’m not looking for the right thing or the right place ?

EDIT. Volumio pull @16%. Be back if a few minutes :slight_smile:


Michelangelo you’re a genius ! Long life to you and Volumio \o/

PS. Not sure I can understand but what was wrong ?