SOLVED - 2.041 to 2.114 breaks FLAC decoding

Upgraded from RPi2.041 to 2.114 and a few hiccups on the update, but I can live with those, as long as it works, but it doesn’t. Did an in-situ update, and now when I try to play a FLAC file from the NAS, I get a small red error box stating

Failed to decode ’

where file is the FQDN for the desired track. This happens even after deleting the mount point and re-introducing the NAS to Volumio.

Could you try to delete “user data” and see if that helps?

Depends on ‘helps’ :slight_smile:

RPi now catatonic after 10 minutes, ssh not answering, WebUI either unreachable or, on the original screen, the circling balls. BRS time…
RPi no longer booting, will re-image SD card and comment.

Chris M

Before reimaging, remove power and give it again

OK, that works, albeit at the cost of the playlist… no biggie.

Looks like something didn’t quite go right on the in-situ update but I’d not worry about it until more than just me has the issue…


Chris M

Just saw your update; no, the BRS did nothing, so that’s when I went to re-imaging…

And the answer to this is: ignore the fact that it worked just fine yesterday, and throw the SD card away. I’d formatted it at least 4 times today, always without any signs of trouble; free space etc. all looked good, but replacing it and all works well. Hey ho…

Hmm, I had a problem with ssh after updating through the UI, but works fine by flashing official image. Also, problems reported by another poster after updating via interface.

So I may have jumped to a conclusion by throwing away my SD card?

Did you install stuff by hand on your previous image?

Nope, gave up doing that after the jump to Vol1 from RaspyFi. For the Vol 2.041 and 2.114 releases, simply a matter of formatting SD card then blowing the IMG file over it. anyway, I pulled the SD card out and it’s back as a spare… Does the fix for the OTA need an update in itself?

2.114 to 2.118 in-situ update(RPi) went perfectly, all working. Nice one, @Michelangelo!