[SOLVED]2.029 crash when playing file with 48 kHz samplerate

EDIT 2: Solution in bottom post!

Hello Everyone,

I recently bought me a HifiBerry DAC+ with a Raspi 2 enabling to play my music collection on my audio installation.
Yesterday I noticed that when I play a certain song volumio plays for a few seconds and then semi crashes. The WebUI dies and won’t respond to any input, and my SSH connection dies immedeatly. I do not know if TTY1 still is up since I am using it headless.

I noticed that the MP3 tags had [ ] in them, which I removed because I read somewhere that these special characters can cause issues. But even after removing the player unfortunately dies.

Has somebody encountered something similar? Is there a way where i can determine what is going wrong? I am a linux n00b (I have a bit of basic knowledge, but that’s really it.).


Edit: just tested with another 48 kHz (320 kbps) file and this really seems to be the culprit.

A quick bump. Could somebody be so kind to point me a bit in the direction where I can start to troubleshoot? Where are the log files kept and do they “survive” a reboot? The system completely freezes I cannot do anything from the CLI via SSH.

The player also crashes when playing a FLAC file with a sample rate of 48 kHz.

I’ve tried to shutdown the system with an USB keyboard and this succeeded. So TTY1 still is up when this all happens. Can someone point me in the right direction?

Ok, the bug hunt continues, it would be nice if someone could help me out a little because of my limited knowledge in regards of the inner workings of Volumio :wink:.

Anyways, these threads came to my attention today: tablix.org/%7Eavian/blog/ar … erference/

So I hooked up my Raspi to my TV for testing (so I can see tty 1 at least when it dies) and I’ve found the following. The 48 kHz files (mp3 and flac) play just fine when the Raspi is connected to ethernet. (I have no sound to test at that location though, but the system keeps running fine so I assume the playback is working as it should.) A WiFi dongle is present and connected as well at the time of my test.

As soon as I unplug the ethernet cable the player dies after a few seconds of playing, sound gets choppy and the WebUI becomes unresponsive. The counter keeps counting whilst the spinning thing is over the webUI. This is what I’ve seen in the debug window:

{"status":"play","position":205,"title":"10,000 Feet","artist":"Wolfmother","album":"Cosmic Egg","albumart":"/albumart?web=Wolfmother/Cosmic%20Egg/large&path=%2FINTERNAL","uri":"mnt/INTERNAL/06 - 10,000 Feet.mp3","trackType":"mp3","seek":366093,"duration":242,"samplerate":"48 KHz","bitdepth":"24 bit","channels":2,"random":null,"repeat":null,"consume":false,"volume":89,"mute":false,"stream":"mp3","updatedb":false,"volatile":false,"service":"mpd"} Play Queue

A few minutes later this is in the same window:

{"status":"play","position":205,"title":"10,000 Feet","artist":"Wolfmother","album":"Cosmic Egg","albumart":"/albumart?web=Wolfmother/Cosmic%20Egg/large&path=%2FINTERNAL","uri":"mnt/INTERNAL/06 - 10,000 Feet.mp3","trackType":"mp3","seek":787892,"duration":242,"samplerate":"48 KHz","bitdepth":"24 bit","channels":2,"random":null,"repeat":null,"consume":false,"volume":89,"mute":false,"stream":"mp3","updatedb":false,"volatile":false,"service":"mpd"} Play Queue

Seek just keeps on running and running and there is no way to stop MPD or to select another song. I can reboot the system via the CLI on TTY1, accessing the device via SSH is impossible when this bug occurs. For what I’ve tested it didn’t matter if the 48 kHz file was on a share or on the local SD card. Both times the WebUI sortof crashes and there is no way to get MPD going again without a reboot.

Please help :wink:


Edit: I’ve just changed my router over to channel 10 as someone suggested on github and now it works like a charm! It appears that that the clocks on the HiFiBerry DAC+ Pro interfere with the WiFi signals. For more details please refer to the link I’ve posted above.