Solution to fix spotify in Volumio 1.5

If you’re having issues with spotify, here’s how i fixed it (raspberry pi b+, volumio 1.5x)

turn spotify on in volumio using your browser, add your (premium) credentials, an click apply. Reboot (my reboot button in the web UI does not work, so you may want to do it through SSH using “sudo reboot”).

in ssh, run the following command:


you should not see spopd service running. If you check the log file “cat /var/log/spopd.log” you will get the following error:

2015-01-05 20:09:18 [ERR ] Can’t load sox audio plugin: cannot open shared object file: No such file or directory

now edit manually your config file:

“sudo vi /etc/spopd.conf”

and make sure it is IDENTICAL to this one below. Delete the [sox] line, and modify anything that is differnete besides your credentials obsiouvly. Mine had the audio_output = sox (which i changed to ao), and the output_name was different too. make sure to save with :wq when done in vi.

volumio@volumio:~$ cat /etc/spopd.conf
spotify_username = XXXXXXX
spotify_password = XXXXXXX
audio_output = ao
output_name = hw:0

When done, restart your spopd service.

sudo spopd -c /etc/spopd.conf

if you run pstree you will see spopd running. you can also check your log /var/log/spopd.log file to see if there’s any error in the login sequence.

You can go back to your browser and you will have the spotify menu. I’m not 100% sure spopd service will come back up when you restart though, you may have to start it manually or run a cronjob. i did not find (laziness…) where volumio calls the service. i checked quickly in /etc/init.d but no luck.

now my spotify is empty of anything but that’s probably because i’ve never used it. :exclamation: :exclamation:


Wait, this guide has one fundamental problem:
did you updated the webui before doing that? I think yes, because this is not necessary with clean volumio install.
So, everyone shouuld use clean volumio install, and there’s no need to apply this.

this was a fresh install, i had tried setting it up (and it was still setup) through the webui.

considering the fact that I found multiple posts about the same error, I’m guessing it is not just me.


their fix in this post is to “reinstall”, and folks who tried that did it multiple times before (if) it works.

Anyway. If that can help someone then good! I spent half an hour trying to figure out why it was not picking it up.

This works for me, in that Spotify now shows up in the Browse menu where it didn’t before (even after enabling it in the GUI, multiple reboots, etc.) however I do not see any of my saved albums, just two empty categories called “Starred” and “Windows Media Player”.

Yes, the Spop daemon currently only reads your playlists, and not saved tracks/albums. I’m interested to see this feature added too! :slight_smile:

We might add this as a suggestion to the Spop repo.

Thanks! This fix worked for me (Pi A+, cheap no-name DAC, Volumio 1.5), but I noticed that when i tried to lower the volume (software controlled, not hardware because of the no-name DAC being a bit finicky), nothing happened.

Everything from Spotify played on full volume, despite the volume control being turned down. When I stopped playing music from Spotify and resumed playing streaming web radio, it played on lower volume, just as the control indicated that it should do.

i used the info in this guide to fix my spotify issues which as it happened weren’t quite the same, but i got the gist of the error from the log files

so anyone else having issues with spotify in volumio 1.5, look in /var/log/spopd.log

my issue was that when i put my spotify password into the web admin, it didnt use the numbers in my password, it translated them to letters and so i was never going to be able to run it. i saw this in the conf file after finding the log file said unable to log in.

now if only i could work out how to push my spotify output from my iphone to volumio, i’d be set.

hello all,

Just got the Premiuim account with Spotify and of course, as probably you all expect this, I can’t make it work with my Volumio on my RPI B+ and an IQaudio Pi DAC+. Everything else works like a charm, NAS and Webradio but no Spotify!

I’ve input Spotify credentials numerous times, rebooted Volumio numerous times but still Spotify won’t appear as option in Volumio GUI.
Tried everything and all tips already posted here to no avail.

Really need your expertise and please, just please, don’t tell me to re-flash the SD card. I’m looking to find the culprit here not only to get it work (even though that’s the ultimate goal, indeed). I don’t want to use a “windows” tip: got BOD? reboot your PC!

so, here’s what I’ve done so far:

pstree shows no sign of spopd running;

sudo nano /var/log/spopd.log

2015-06-04 23:17:04 [ERR ] Error while reading string “spop::spotify_username” in configuration file: Key file does not have group ‘spop’

pi@volumio:~$ spopd
spop Copyright © 2010, 2011, 2012, 2013, 2014 Thomas Jost
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under certain conditions.
See the COPYING file bundled with this program for details.
Powered by SPOTIFY® CORE

2015-06-04 23:34:22 [ERR ] Can’t read configuration file ‘/home/pi/.config/spop/spopd.conf’: No such file or directory
Trace/breakpoint trap

I’ve looked into the spopd.conf and indeed, it’s empty.

How can we fix this?

much appreciated.


check the content of the file /etc/spopd.conf (credential passwd)
kill spopd and a restart it sudo spopd -c /etc/spopd.conf

I’ve just mentioned that spopd.conf file is empty! there’s nothing in.


Is there anyone that really cares and perhaps can help me with this? (see my post regarding Spotify and Volumio)
I’m using Volumio and found this product as amazing but if no one can give me some directions while I’m here in VOLUMIO FORUM than I don’t know what else to do! How can we grow and make a product even better if we can’t or won’t work together? That’s the whole purpose of open source, community, etc, I guess.

much appreciate your time.


First of all, sorry if you still haven’t found a solution to your problem.
But, as you said, Volumio is an open source project, and you have to keep in mind that people answering on the forum are doing it their free time and sometime, nobody have the solution for you… :confused:
I don’t understand why your /etc/spopd.conf is empty but create it manually sudo nano /etc/spopd.conf and paste the following in it :

spotify_username = yourspoptifyname
spotify_password = yourpasswd
audio_output = sox
output_type = alsa
output_name = plughw:0

save and start spopd deamon : sudo spopd -c /etc/spopd.conf ( kill it before if already running)
Now, you sould be able to see Spotify in your source.


you’re the MAN. Can’t thank you enough.
about this issue, I did created manually but it looked like your file options had different settings for [sox]. Now I can see Spotify in the Library sub-menu;

About the help… I hear you and I totally understand you. But think a little bit, ppl jumps on Forums mostly when they need something or they have an issue. I don’t take things for granted but if I can help someone I’ll try my best to do it, of course, when I can. Looked at you. you found a minute to reply back to my issue. I’m grateful for that. We should all be there when someone’s in need. You never know when your turn will be :slight_smile:

Thx again.


You’re welcome!