Snapcast error

When I try to chahge a snapcast client setting I get this message;

Restart failed
Restarting snapclient failed with error: Error: Command failed: /usr/bin/sudo /bin/systemctl restart snapclient Failed to restart snapclient.service: Unit snapclient.service is masked.

Is this normal?

I have the same issue

Same here…

Verstuurd vanaf mijn SM-G960F met Tapatalk

Have you manually installed snapclient or installed as a plugin? Sounds like a problem with your installation. Or possibly that you have altered something without reloading the service file.

I’ve done both, installed manually and from the plugin menu. Same result.

System Information
OS info
Version of Volumio: 2.699
Hostname: musicserver
Kernel: 4.19.86-v7l+
Governor: performance
Uptime: 4 days, 16 Hrs, 6 Minutes, 34 Seconds

Audio info
Hw audio configured: Schiit Modi 3
Mixer type: Hardware
Number of channels:
Supported sample rate:

Board info
Manufacturer: Raspberry Pi Foundation
Model: BCM2835 - Pi 4 Model B
Version: b03111 - Rev. 1.1
Firmware Version: Nov 29 2019 18:44:32 - aabb1fb5c19d80db268aeccd67b9f4e0f3d48a2a

CPU info
Brand: Processor rev 3 (v7l)
Speed: 1.50Mhz
Number of cores: 4
Physical cores: 4
Average load: 0%
Temperature: 44°C

Memory info
Memory: 2031168 Ko
Free: 1035760 Ko
Used: 995408 Ko

Storage info
INTERNAL storage - Size: 27484Mo Used: 228Mo Available: 25838Mo (94%)

I wonder if your problems arise because of both manual and plugin installation, and then not totally removing one to try the other. It’s difficult to offer advce when you don’t know exactly what has been done, but if you haven’t invested too much time in your current setup, I would personally try a fresh installation of Volumio, and then go for the plugin installation. I recently installed the plugin without your problem (I had other problems :wink:) on v.2.699.

Try to bring this back to life…
Need some help :slight_smile:

Network over Ethernet
Volumio Ver.: 2.714
SnapCast Plugin Version: 2.4.3

i did:

  1. Installed Volumio ( with Balena Etcher on my 16GB SD Card
    1.1 Setup the Volumio over WebUI

  2. Installed SnapCast Plugin over Volumios WebUI

Downloading plugin at …
Erstelle Installationspfad
Plugin wird entpackt
Prüfe, ob Plugin bereits existiert
Kopiere Plugin in sein Verzeichnis
Installiere benötigte Komponenten
Installing SnapCast and its dependencies…
Get:1 jessie InRelease [14.9 kB]
Get:2 jessie InRelease [22.9 kB]
Get:3 jessie/main Sources [7762 kB]
Get:4 jessie/contrib Sources [64.5 kB]
Get:5 jessie/non-free Sources [113 kB]
Get:6 jessie/rpi Sources [1132 B]
Get:7 jessie/main armhf Packages [9539 kB]
Get:8 jessie/contrib armhf Packages [43.3 kB]
Get:9 jessie/non-free armhf Packages [88.1 kB]
Get:10 jessie/rpi armhf Packages [1356 B]
Get:11 jessie/main Sources [57.1 kB]
Get:12 jessie/ui Sources [17.4 kB]
Get:13 jessie/main armhf Packages [171 kB]
Get:14 jessie/ui armhf Packages [58.9 kB]
Ign jessie/contrib Translation-en
Ign jessie/main Translation-en
Ign jessie/non-free Translation-en
Ign jessie/rpi Translation-en
Ign jessie/main Translation-en
Ign jessie/ui Translation-en
Fetched 18.0 MB in 38s (467 kB/s)
Reading package lists…
Detecting cpu
cpu: armv7l
Selecting previously unselected package snapclient.
(Reading database … 25447 files and directories currently installed.)
Preparing to unpack …/snapclient_0.19.0-1_armhf.deb …
Unpacking snapclient (0.19.0-1) …
Processing triggers for systemd (215-17+deb8u8) …
Selecting previously unselected package snapserver.
(Reading database … 25456 files and directories currently installed.)
Preparing to unpack …/snapserver_0.19.0-1_armhf.deb …
Unpacking snapserver (0.19.0-1) …
Processing triggers for systemd (215-17+deb8u8) …
Reading package lists…
Building dependency tree…
Reading state information…
Correcting dependencies… Done
The following packages will be REMOVED:
snapclient snapserver
0 upgraded, 0 newly installed, 2 to remove and 24 not upgraded.
2 not fully installed or removed.
After this operation, 2315 kB disk space will be freed.
(Reading database … (Reading database … 5% (Reading database … 10% (Reading database … 15% (Reading database … 20% (Reading database … 25% (Reading database … 30% (Reading database … 35% (Reading database … 40% (Reading database … 45% (Reading database … 50% (Reading database … 55% (Reading database … 60% (Reading database … 65% (Reading database … 70% (Reading database … 75% (Reading database … 80% (Reading database … 85% (Reading database … 90% (Reading database … 95% (Reading database … 100% (Reading database … 25468 files and directories currently installed.)
Removing snapclient (0.19.0-1) …
Removing snapserver (0.19.0-1) …

pcm.!snapcast {
type plug
slave.pcm snapConverter

pcm.snapConverter {
type rate
slave {
pcm writeFile # Direct to the plugin which will write to a file
format S16_LE
rate 48000

pcm.writeFile {
type file
slave.pcm null
file “/tmp/snapfifo”
format “raw”

  1. reboot volumio

  2. enabeled SnapCast Plugin over Volumios WebUI

i got:
Could not start the SnapCast plugin in
a fashionable manner.

Restarting snapserver failed with
error: Error: Command failed:
/usr/bin/sudo /bin/systemctl restart
snapserver Failed to restart
snapserver.service: Unit
snapserver.service is masked.

im not really into that programming thing, but i will do my best to understand your suggestions

Hey Guys,

I was getting the same snapcast error, and its broken due to the version of snapcast that is used, 0.19.0 requires dependencies that are not apart of the Jessie Raspberry Pi build, as a result 0.19.0 will not install. On another thread, a user by the name of TomR posted a manual install workaround, that gets snapcast working, and uses build 0.15.0

I just tried this and snapcast works and starts with no errors.

If you follow TomR guide there, you should get snapcast working and starting without error.


Work around starts after initial install but after reboot it wont restart

What works for me is the „pre plug-in old installation method“ from „Sayato“ - worked today on a fresh install, just be aware that the MPD patch seems not to work fully and Snapcast server needs to be on 44,1khz/16bit - before I used 48 khz as suggested, that creates sound issues as (assumed by me) the MPD patch is not working fully as above.
Procedure copied from Sayato (btw: HUGE thanks for all your work!!!) :

Lazy installation of unsanctioned versions (quick version)
1. SSH into server
2. Execute the below command:
sudo wget -O …
This will download the installation script.
1. Execute the script (DO NOT USE sudo!) you’ve just downloaded using the below command:
sh Saiyato volumio-snapcast-plugin



Hi @DirkST,

Good reading! Like how you deductively solved your issue.
I too saw that MPD config was still 48kHz (not sure why I ever said that was standard…), in any case, that should be solved now.

Why does the installation from the plugin store not work? Well it’s some commits behind my personal GitHub repo, and somewhere along the road Jessie was no longer supported by the ‘latest’ SnapCast builds. So I had to lock v0.15 for Jessie in the plugin install script, which should be LIVE now, but I’ve been too occupied to follow all my PR’s. Will be working on the plugin this week. :wink:

Also posted some info here: Snapcast config - #5 by Saiyato