SMB server with OpenMediaVault (OMV)?

Hi to all!

I moved all my files out of Volumio RPI and moved them to a NAS at another RPI where I installed OpenMediaVault.
As I do not need SMB anymore, I thought that disconnecting Shairport.Sync, enables SMB sharing. I still see Volumio SMB at my Mac. In Fact I can access over this Volumio Sharepoint then as connected to the NAS RPI. Is there a way to unable the service?

On the other side, the strange thing is that the OpenMediaVault SMB service is much slower then the one Volumio has build in. Does anyone know why? Its not a big deal, as I don’t copy so often new music to the disc, but it is al least 2-3 time slower that Volumio one. Does anyone had this problem?

Thank you for your help!

Simply hardware limitations of the rPi.

But why is it much faster with the smb server installed in Volumio, with the exactly same hardware?

And how can I turn off at the RPI of VOLUMIO the SMB server?

Thank you!

shairport-sync is your Apple Airplay capability, it has no relation with sharing data via SMB.
As far as I know, there is no way to disable the SMB server via the Volumio UI.

An educated guess, as I never used a rPi as nas.
If you connect a USB disk to a volumio hosted pi, you bypass SMB, as you simply connect to a mount /mnt/usb/…
When you use a 2nd rPi, you suddenly add multiple components to the chain:

  • Volumio SMB
  • NAS rPi SMB
  • NAS rPi USB
  • Network

Hence, why I mention to get a reasonable priced NAS like the TR-002, in your previous topic.

Thank you for your reply. The decision to use a rip as a NAS is because I have all the components already. Of course I can try to invest in the future another NAS.

My first setup was to have the primary RPI connected to the USB drive, and the secondary Volumio RPI, connected to the shared disk of the first VOLUMIO over the Volumio SMB server.

In any case, after disconnecting the USB drive from the fist RPI, the Sharepoint of Volumio showed up.
So my question is, if it is possible to tell Volumio to disconnect them. That would help for sure even if an integrated NAS solution is connected to the network.

Even before installing the RPI NAS, the 1st Volumio and the second Volumio (even is there are no drive connected, show as shrepints in my Mac OS X. There must be a SMB service enabled.

I managed to disconnect samba by this command:

sudo service smbd stop

Now the share points don’t show up, and I imagine that it is better for Volumio, to lower the use of background tasks.

It is not going to make any noticable difference, but when it makes you happy😉
This system change will probably have no influence on OTA updates, but remember it in case the update complains.

The problem is that it showed up on the network all the time and if it is not necessary, better to have it not running.

What I will try is to install a new RPI with this service enabled, as Volumio was much faster that openfilevault. I don’t understand why.

But coping a 3GB dsd album takes 3-4 minutes, when with Volumio it took less than a minute.

1 Like

Didn’t I list it out in my previous post?

I connect to the Nas directly from Mac.
When I connected to Volumio (when the usb was connected directly to Volumio rpi) it is much faster.
It seems that the samba sharing in the Volumio os is much better then the openfilevault nas software running on rpi lite 64 bit.
But this is not an issue of Volumio of course. I am just wondering how to get the nas running with this solution. Still investigating.
In any case thank you for your help!


It was as simple as the ethernet cable. In my Volumio RPI I have an Audioquest Pearl Eternet cable plugged in. In MY NAS I have a normal cat 5e cable. I switched the cables, and voilá I have again my fast speed. I will just order a CAT 7 cable (the one from audioquest is cat 7), to obtain the right speeds.
(With cat 5e (maybe broken cable), I manage speeds of 2 min 16 sec for a 1,5 GB file. With Audioquest cable 21 sec.).

BTW. I don’t think that an audiophile cable would be needed for the NAS. Maybe I´ll give it a try and order one from amazon. In case it doesn’t help I send it back.

perhaps when one of the leads is broken, the cable causes a fallback to a 4-wire connection, which means 100Mbps max.

I changed the title of this topic because shairport-sync has absolutely nothing to do with SMB or other filesharing services and therefore only confuses newbies.

Thank you for your reply. I tried another cat5e cable and it worked much better. So It was not OMV, but only the cable.
Thank you very much for all the effort!