Skipping in Spotify playback -- normal?

Hello I have 1.5, B+ and iq audio DAC+ - every 45 seconds to 60 seconds I hear a skip when playing a spotify play list. I have updated the buffering to 30% and the playback is on “fastest” – wondering if this is common for the 320kbps play back or atypical.

The only time I’ve experienced skipping with Spotify is when my SD card was nearing its storage capacity. Did you install any extras on your RPi by chance?

Well I have a naked 8GB card that volumio is installed on - no additional files other than from apt-get update. I doubt the volumio install is near 8 gb is is?

Also a curios thing I’ve noticed is that though my wireless connection is listed by volumio as 74 gbps the connection strength is listed as “14%” - no idea how it’s quantifying that – or even that it’s valid since it is five feet from my router.

Hmm you could try to increase the Spop cache size and see if it helps. Just point a text editor to ‘/etc/spopd.conf’ and add the line

cache_size = 200

This sets the cache to 200mb. By default, “cache_size” is set to ‘0’, which apparently means 10% of disk free space.

Also, the Volumio image has a root partition that is only 1.5gb, so you might not be using your 8gb card to its full potential. Check this thread for instructions on how to increase the partition size:

If you do that, I’m pretty sure the 10% cache setting is more than enough! :wink:

I have the same problem with playback from Spotify. I expanded the root partition to 3.6GB, of which 2.6GB is free, but that did not help. I also set the cache size to 500MB in spopd.conf but that did not help either. If anyone else have a suggestion on how to solve this I would be very grateful.

I too am experiencing the same issue. RPi B 8GB SDCARD WIFI.


I’m having the same problem. RPi B, HifiBerry Digi. Local music is fine.

Is it possible to enable logging for Spotify?

Thanks for all your hard work,

Rook mentioned in this post that switching to a faster card seems to clear up the problem. Let me know if this works for you also!

A new SD card may not be required at all. I was helped by a 20MB cache in RAM instead. Check the keab post here:

I have made these changes, and I hope that it will fix the problem.
No ‘gaps’ until now, so it looks promising! :slight_smile:

UPDATE: I have not noticed the skipping problem until now after my previous post, so it looks like this problem is definitely solved using this method :slight_smile:
:slight_smile: .