Several problems with unconnected Volumios

I’ve several Volumios at home, which are suddenly not connected.
I can’t really identify the problem, because everything else works fine in my network (with other Raspberries and other OS).
The Volumios are not present with the web-interface. When I open the IP-Address, I get the message, that the device ist not accessible.

I’ve tried new installations on new cards.
I’ve tried to replace the network cables.
I’ve tried to use other Raspberries.
I used version 2.672 and 2.657. Same effect.
The Raspberrys are for example Version 1 Mod. B+, 2 Mod V1.2, 3 Mod B+ and so on. All different, but all the same errors.
I Use only Sandisk Cards. Some 8GB, some 16GB.
Some Volumios start and I can set up the devices. After some hours they are not available, too.
Has anybody else this problem? I’m in a fix.
Thanks a lot for your reply!

Yes. I have 2 rpi 3 model B. Both could not be left running as they would stop talking - sometimes they worked for a day or so before clamming up.

I have just bought an rpi 4 and updated to the latest volumio version. Only been about 20 hours so far, but still working.

I currently have 4 Volumio’s running - on Rapberry 1B+, Raspberry 2B(old V1.1), Raspberry 3B+ and orange pi PC, they all running without problems so I don’t think PI model is a problem. I have them all set to DHCP but reserved IP for each of them in my router. I also had to add lowESR electrolytic capacitor 2200uf 6.3V to B3+ board 5V because it constantly had low voltage warnings. Must also add that Pi1 web interface is very slow and it had some problems with high bit-rate files, Pi 2 has minimal interface lag but is perfectly usable, Pi3+ is just excellent. I think maybe you have problem with IP address changing or problem because unstable power. I also had not working Volumio because of corrupted SD-card when i switched off power during boot. Must mention that all devices are connected to wired network and use i2S audio, I only play FLAC and MP3 from Windows7 share.

I am having the same problem.Rpi 3b+, sandisk sd card 16gb.After a few hours volumio just hangs and cannot be reached, power cycle solves the problem.

Edit: Connection is via wifi, I will try if cable makes any difference.