Setting up 7" touch screen 1024x600 resolution

Hi, a friend gave me a 7" touch screen that he’s not using. nice of him.

I added it to my RP3B+ with the touch plugin installed and it worked right away.

However, the resolution is 1024x600. I notice the official raspberry pi screen is 800x480. I have the screen rotation set to 90’ and the content of the screen appears stretched vertically. Same with no rotation but stretched horizontally. Is there a way I can tweak the settings to support this resolution?

1 Like

What is the brand and exact model name of the screen?

1 Like

Great question!

It does not seem to be marked. However, in the instructions (which also don’t mention a brand or model) that came with it it says to edit the config file for rasbian to make it work.

Could it be that I add the same text to the config file of Volumio?

Step 1, Install Raspbian official image

Step 2, modify the “config.txt”

Open the config.txt file of TF card root directory and

add the following code at the end of the file, save and eject Micro SD Card:

hdmi_cvt 1024 600 60 6 0 0 0

It says for info go here ( - however, this looks slightly different to the model that I have and the code that it says to add on this page is slightly different to the one above from the instructions.

If the screen is connected by HDMI I would suggest to try adding the following entries to /boot/userconfig.txt:

hdmi_cvt=1024 600 60 6 0 0 0

Using userconfig.txt has the advantage that your own entries remain untouched when Volumio gets updated. In contrast /boot/config.txt file gets overwritten (further information).

Since max_usb_current=1 and hdmi_force_hotplug=1 are already part of the “standard” /boot/config.txt there is no need to add them to userconfig.txt, too.

I can’t say if config_hdmi_boost=10 is required. As stated here the default value for your Raspberry should be 5. Personally I would start with the default value and change that only if HDMI issues as described in the previous link should occur.

1 Like

This worked. It looks a lot better now.

I have not added config_hdmi_boost=10 yet. Things seem ok for now, will test more thoroughly through the day.

Thanks very much for your excellent guidance.

1 Like

i have just the settings of this site :slight_smile:

It works perfect for me. Display model CLB7INH, USB Touch rev. 2.0

A post was merged into an existing topic: [PLUGIN] Touch Display