Screentimeout on 7'' RPi touchscreen

i successfull installed the RPi 7’’ touchscreen on my RPi3 Volumio2.

works fine. But there is no screensaver… the screen is always on.

is there a way to let volumio or the screen go to sleep?

I think it would be great if someone could write some extra code, to let the screen go in powersave mode and just display the time. this would be a great feature for clockradio-DIY projects.

Can someone put me in the right direction to ‘Putty SSH’ in Volumio and play with some code?

I’m in the same boat, right now. I’d be happy with a blank screen or even better some visualization effects like some of the old winamp plugins.

for now i installed rasbian on the RPi, en running volumio webUI. After couple of minutes the RPi goes into sleepmode. one touch on the screen and there is volumio again…

Just edit with following commands on the commandline

cd opt
sudo nano

Originaly it looks like this:

#!/bin/bash xset -dpms xset s off openbox-session & while true; do /usr/bin/chromium-browser --disable-session-crashed-bubble --disable-infobars --kiosk --no-first-run 'http://localhost:3000' done

edit the lines:

“xset -dpms” to “xset +dmps”
“xset s off” to “xset s blank”
and add the line
“xset dpms 0 0 120”

it should look like this:

#!/bin/bash xset +dpms xset s blank xset dpms 0 0 120 openbox-session & while true; do /usr/bin/chromium-browser --disable-session-crashed-bubble --disable-infobars --kiosk --no-first-run 'http://localhost:3000' done

save the changes and reboot the machine. After rebooting the screen schould turn off after a few minutes and turn back on on fingertip…

greetings from Austria

1 Like

Thx faity, i’ll give this a try tonight.

Would it be to simplistic to set “xset s time” to display the current time at screentimeout?

i’m trying to use the screen as a clockradio in the bedroom.
So volumio control for all the RPi’s and at night the time on the screen…

Clever! What about helping via a Pull request? So everybody can have it

Nice, having the same issue. i will test the screen timeout.

Second, It would be nice if we could set a screensaver with pictures to have a photo frame.


Thank you very much this helps me very much!

worked for me - thank you for sharing :slight_smile:

dear faity,
i had to change xset 0 0 120 to xset dpms 0 0 120 to make it work, which it now does like a charm :wink: much better than my xcsreensaver attempts and it also survives a reboot. thx a lot!

works great. thx!

is it possible to add the time to the screen as a screensaver? would be ideal for a clockradio.

Thank you for this correction. I completet my origonal posting with this edit…

Thank you for sharing this!

I have one question: my screen (Waveshare 10.1" IPS touchscreen) does go blank after two minutes, but the backlight stays on. Is there any way to make it turn off as well?

Just tried this - works like a champ! Thank you.

Thanks, this is just what I was looking for!

I was hoping to make a tweak, is there a way to leave the screen on while music is playing?

I’d love to have the screen on when something is happening, and only shut off if the music stops. So I guess I’m looking for the timer to be based on audio, not touches on the screen.
Ideally, I’d love the screen to turn on when the music starts too.

Thanks again for the help

Edit: My apologies: Upon closer inspection in a dark room is seems like the backlight is actually off. I must have seen external reflection when I checked in the afternoon. So please ignore my posting (except maybe for the postscriptum).

The current Volume release has this patch built in.

However: It doesn’t really work. While the screen looks blank, the backlight is still on. I usually leave the Raspberry Pi constantly on, even if I don’t currently listen to music. If the backlight remains on, the power consumption is significantly higher.

Does anyone know how to turn off the backlight when the screensaver kicks in?

I am talking about the “official” 7" display. For an HDMI connected screen, one would add this to config.txt:

Thanks! Martin

P.S. For the ultra, best experience, I’d love for the screensaver to only kick in if no music is currently playing. As it is now, I have to tap the screen every time I want to know what is playing.

Same request as Tinue: For the ultra, best experience, I’d love for the screensaver to only kick in if no music is currently playing (maybe after 2min of inactivity). As it is now, I have to tap the screen every time I want to know what is playing.

Any possible solution?


is there any solution now, for showing the time as screensaver?


Can the time to screen turn off be adjusted?
I would like it to shut off after about 30 seconds.