SBC for 192 kHz / 24bit over HDMI

Volumio Information

Volumio Version:2.907
Hardware: Pi 3B+; Allo Kali Reclocker
DAC: Allo Piano 2.1


since the new Version of Volumio did not let me use my DAC normally, I wird my Pi through HDMI into my amp. (I used a Allo Piano 2.1 with reclocker.)

Surprisingly that sounded good and the music Had well defined room.
But I know that ist not bitperfect at all and i want the best possible.

I found that because auf the bcm the alsa driver of the Pi 3b ist resampling all to 48kHz and 16bit.

Is there another SBC that ist not resampling?
Maybe the Pi 4b?
Or a SBC from hardkernel?

Thank you for your Help!

Sorry but I don’t understand…
You talk about hdmi, piano and bcm… Three different things.
If you use Piano+reclocker (Kali?) this can be bitperfect.Just use it!
Output from the RPI headphone jack is rather poor in quality.

Hi, sorry for my bad Englisch. I try explain it.

I used the reclocker and piano till the last volumio Update.
But with the Update i just got sound out of the right speaker.
I wanted to listen to music but had no time. So i switched to HDMI. I wanted to change it back later.

But the music sounded way better than i expected.
With more “space” to it. Maybe the DAC in the amp is better than expected.

I thought about keeping it that way through HDMI. But I only got 48kHz even with 96kHz or 192kHz music. Maybe i can not even hear any difference but i want what i pay for… :wink:

That ist why i thought about changing the Pi 3b for anything thats not limited that way. If that ist possible.

Hi ManInBlack4444,

Sorry for having no answer regarding an SBC that doesn’t have this HDMI limitation of the Raspberry PI,
but if you are looking for a workaround for the Kali/Piano2.1 (Dual Stereo) solution - here is the trick how it works on the current versions (many times tested with 2.906; 2.907 and the latest v3 beta versions):
I do have 4 pieces of KALI/Piano2.1 combinations running (3 for testing).

In audio settings:
1.) Choose “No I2S” and set to Audio jack - then reboot
2.) Choose “I2S” and select “Allo Piano 2.1” - then reboot
3.) Now the settings for “Dual Stereo” are offered in the interface - choose it and - then reboot
4.) Now the settings disappear and no sound is working, but now you get the Piano offered in the dropdown, where you usually change between HDMI and audio jack - choose the Piano 2.1 there and one times more - do a reboot
5.) It’s kind of wierd - but now the Piano is working in real “Dual Mono” mode and the sound is fine.

I hope the Volumio team will get this back to normal some day :slight_smile:

btw. What Amp (i guess with HDMI input) do you use ?

Best Regards


I will try your way, maybe that’s a way to get it running.

But the limitations of HDMI are still sad for me.
Maybe a Digital Output ist the way to go then.

The amp I use is an “old” Onkyo TX NR 905.