Samba full access

I needed to copy some files to places on Volumio other than the standard Samba shares, so I edited the smb.conf file to get acces to / and restarted Samba. This worked until I rebooted! So the boot reinstalls the original configuration files.

Is there a way to change this boot behaviour, even temporarily? It could be an option in the WUI for instance.


Hi guussie,
you have to make a little mod on the PHP code.
Edit this file: /var/www/inc/player_lib.php

look at line 1174 :

// /etc/samba/smb.conf $a = '/etc/samba/smb.conf'; $b = '/var/www/_OS_SETTINGS/etc/samba/smb.conf'; if (md5_file($a) != md5_file($b)) { sysCmd('cp '.$b.' '.$a.' '); }

comment from 1174 to 1178:

// /etc/samba/smb.conf // $a = '/etc/samba/smb.conf'; // $b = '/var/www/_OS_SETTINGS/etc/samba/smb.conf'; // if (md5_file($a) != md5_file($b)) { // sysCmd('cp '.$b.' '.$a.' '); // }



Thanks Simone, that worked. But for some reason I can’t alsoways see the files in Finder on my Mac. Perhaps a networking issue.

What’s the difference between Volumio and RuneAudio other than the different Linux version?


Orion: and what about edit file in /var/www/_OS_SETTINGS/etc/samba/smb.conf ? :slight_smile: That could be easier.

Yep… this is the right solution…
Next version will have all this security mechanism turned off…