Samba and Volumio

Hi every one,

I recently had the (fabulous) pi and I’m struggling to make it work !

Volumio is OK, wifi is OK, i’m reaching the webUI (long struggle without screen, i’m a newbie).

Now, I just want to use Samba to create an access to a specific directory which is in my computer ( because I don’t own a NAS). So I tried creating a samba share with system-config-samba. I had no enough courage to do it the non-GUI way (/etc/samba/smb.conf).
So after creating my mount, restarting ($ sudo service smbd restart), I tried to configure it through the Volumio webUI.

Here is the UI (not very useful, ok):

Here are the options:

And here is the global configuration of Samba:

So in Volumio UI, i tried a random sourcename, fileshare SMB/CIFS, my IP, my directory (/mnt/…), no user, no pass.
Here is the result :
Last system mount error
mount: mount point /mnt/NAS/music_alban does not exist

What should I do next ? :confused:

Thank you for your help !

edit : yeah, 'got a dual boot and music under windows partition (but i’ve mounted it under /mnt/windows)

I just wanted to add that if you have another solution (other than samba) to share a directory from a linux machine with Volumio, I’ll be glad to hear it !

Go for NFS share, performance are better than SMB.

Ok, I’ll try this tonight :wink:

Do you have any advice to share about how to create an NFS server ?

1 Like

I don’t know sorry, my NAS do it for me…

Ok, so I tried to configure NFS. Still not working :confused:

On my laptop /etc/exports


When I try to mount manually the directory :

root@volumio:~# mount /mnt/nfs/music/ mount.nfs: access denied by server while mounting
On root@pi (ssh) :

root@volumio:~# showmount -e Export list for /mnt/windows/Users/Bamban/Music
Any clue, knowing that I achieved THIS tutorial.

1 Like