RPi4 filesystem damage

Volumio Information

Volumio Version: v 2.907 - 2.917
Hardware: RPi4 HW1.2 / Pi Touch screen 7
DAC: Topping E50 / HifiBerry Digi plus pro

Problem: my volumio boots up only for first time and initial setting, then after reboot does not boot up.

If I fix the filesystem in gparted then I’m able to boot up again but then it repeats. So volumio itself is somehow damaging filesystem.

Using Zonepi USB-C 5,25V⎓4A - powerfull enough.
SD card cannot be an issue: I tried several cards, all of them working well on RPi3Bplus, even using recommended cards from raspi shop doesn’t work. Flashed by rufus, etcher, raspi imager… nothing works.
Disabling/disconnecting all HW (display, DACs) running only pure rpi4 doesn’t help.
I even tried several older images but always the same.
When running raspbian from the same cards there is absolutely no problem.
So it must be something with volumio image / partition layout / etc?

Anybody can help?

Thank you!

I see that you have a display: this draws lots of current and if your PSU is not up to the task, it migth cause damage to the SD. I suggest using a beefier PSU

Thank you feedback. But as I mentioned already in first post - the same happens even when I unplug all HW from RPi.

Wait a least one minute when you power your PI. Mine behave like that. After a reboot, it seems dead about one minute before boot start…

1 Like

It is booting (and green led flashing) but stucks few seconds after volumio logo is shown (green led permamently on) - I even waited for 30 minutes in this stuck but nothing happened. Then is enough to gpart / dosfsck / e2fsck fix partitions and I can boot again.

Are you able to tell which partition gets damaged?
Are you installing some plugins?
Do you see a yellow lighting icon on the display?

1 Like

You were right. Even the LED is flashing something goes wrong. If I wait more than one minute before power on then I can boot. But I cannot understand why this is happening to volumio and not to raspbian. And why on RPi4 HW1.2 and not on RPi3 B plus.
Do you have any explanation?

Ditry bit and some offset (I dont’ remeber) of original/backup something on mmcblk0p1 and something else on mmcblk0p2 - this looks to be the main issue out of those 2. Data partition clean.

No plugins - very clean initial setup.

No undervoltage sign on display.

Even when no HW attached to Pi behavior is the same.

@volumio Maybe the partitions check/repair is not significant but due to time of partition check on another PC while RPi was powered off I was considering it to be like fix and/or problem. Now without any partition repair I can boot successfully even without previous partition repair after boot stuck.
So boot, reboot, boot stuck, power off, (no partitions repair), wait two minutes, boot up.

OK @volumio so the partition damage as the cause was misleading information. There is some damage but it is not the root cause for not booting up the system. Sorry I let you loose time with this.
Instead should be good to understand why warm boot causes problems with boot stuck.
RPi3 no problem / RPi4 problem
RPi4 raspbian no problem / RPi4 volumio problem.

Thank you and again so much sorry but thanks to @balbuze with his temporary workaround I could find the partition damage not to be the true cause.

did you try a normal usb-c power supply of 3 amp the one of raspberry?

No coz I don’t have any. But I tried 5V/2A with the same result. 2A is enough if there is nothing in USB or GPIO connected.

2 amp and 2,5 amp will give a undervoltage pi 4 can handle only 3 amp max. that’s what i read.
can u measure your amp and voltage in a way check if it’s giving the right voltage and amp.

i had this one :

and had to deliver 5 amp i real life max what i could get out of it was 1,5 amp.

I can check this (later not today) but if this will be power supply problem then it will be problem always - not on warm boot only and I will see undervoltage flash.

@balbuze what is your power supply please?

Original Raspberry Pi 4 Official USB-C Power Supply 5.1V 3A
but they have it in black to.

I can’t help, but I can confirm that I have run into volumio refusing to boot due to file system damage on a Pi 4 system. I also have the Digi Plus card. My system will run for months and stop working and refuse to boot until I reformat the SD card. I initially thought it was due to the system “browning out” when losing power so I fronted the power supply with a UPS and it still occurred. I find it maddening.

I got the same problem, both DAC with Pi and amplifier were plugged at same extension cord and after I plug 3,5 mm jack some sort of loop happens which messes with SD card and Pi itself.