RPi2 + IQaudiO DAC Plus = Horrible Sound

Hi all,

Really hope someone can point me in the right direction.

I have a RPi 2 with an IQaudiO DAC+ running Volumio 1.55, all connected through high quality interconnects to a good amp and decent speakers. I have tried playing mp3 and flac of varying quality and the sound is just not nice! I get better audio quality playing the same tracks through a 3.5mm jack from my phone.

At first i thought it was the power supply. I have since tried several including a battery to no avail. I have tried Volumio downloaded from here, and the version provided by IQaudiO. I’ve checked all of the various settings i can find on the forum. sudo aplay -l displays the board. /etc/modules has all of the right ones listed. alsamixer settings look correct.

I’m really not sure what is going on. To describe the sound, its like it loses all clarity, high notes especially vocals become distorted and buzzy. Everything starts to merge with no depth to the sound. At first i thought it was just me, but I had a friend over the other day with no interest in hifi and he even asked if I was playing a particularly low quality file without being prompted.

I’m about to flash Volumio again in case i have been unlucky with two bad flashes. But any help would be appreciated, I’m getting to the point of sending the board back.

Is it your first config with this DAC or have you ever used it properly ?
Have you choose iqaudio dac plus in the webUI ?
i own this DAC and it is good sounding. Maybe a hardware problem ?

I’m using the same DAC never had any trouble because of it and it sounds great.

Has it ever worked properly?
Have you set I2S driver to IQaudiO DAC Plus?
Have you checked if the headphone connector ( 3.5mm jack) works properly?

Is it plugged in deep enough on the header? (just under one millimeter header visible)

You could try re-connecting it with your R-Pi it might just help. Or you could have a defective unit… that would suck…

First config, it was a Christmas present.
Yep DAC is selected in the UI.
Not sure, could be a hardware problem I suppose.

I have just dismantled everything and reseated the DAC. I’ll get it connected up later and test with headphones and through the amp.

Out of interest, what levels have people set in the alsamixer?

I have it as aux on a stereo set to 80/82 in the webui. Set the stereo to a volume that is easy to listen to, now I can increase and decrease the volume from the webui if I want. 80 leaves some head room in both directions.

When I need to reset my pi I use a headphone to check if it is working properly. Then 80 is hurting and below 16 starts to become muted. I never really used it with headphones for long. (steelseries 5hv2)

1 Like

The volume level that should be set as a max will depend on the linux kernel version being used AND will also depend on software or hardware volume settings within Volumio. The whole thing is also confused due to the linear and logarithmic volume control difference between ALSA and MPD.

We’ve had 0.1% failure rate on Pi-DAC+, it’s a reliable board but obviously happy to swap out any defective board that ever presents itself.

I’d also suggest looking at some of the other audio distributions out there and doing a comparison, soon there will be RoonLab’s RoonReady support with native Tidal streaming too.

Best regards,


So I dismantled the whole thing, popped it back together, reloaded volumio and I changed the ALSA volume settings as per the iqaudio manual. Sounding great now, so god knows what happened during my initial installation.

One point though, now I have changed the settings in ALSA the volume dial in volumio sits at 0 and i have lost the ability to change the volume from the UI, any ideas? It’s not a huge issue, just means getting off my arse to turn the knob on the amp instead.

I have the same seutp, a pi2 with iqaudio pi-dac+. Have you tried to set the volume arround 80%? I have experienced distortions if the volume set of the iquadio is between 100-80%. Setting it in 80 solved the problem.

That whole story is interesting.
It will be very precious to avoid this kind of situation in Volumio2, by allowing to select the proper volume control and setting max a min levels as manufacturer suggestion

Solved the volume problem, my mpd config was incorrect.

When you ‘Save Changes’ after setting the Mixer Type, it sets the mixer_control in mpd.conf to “DSP Program”, it needs to be “Digital” to match ALSA.

[code]audio_output {

             type           "alsa"
             name           "Output"
             device         "hw:0,0"
             mixer_control  "Digital"
             mixer_device   "hw:0"
             mixer_index    "0"
             dop    "no"


All working perfectly again.

I had the same problem (via DAC+'s headphone amp, distortion with higher volume level), ssh’d into everything, burned sd card repeatedly, disassembled it and put back together again… And I just put the headphone jack half-way in. I found out when I tried another headphones that came with mic and longer jack — I put the box on its side and pushed hard as I knew that jack needed it. Of course that “normal” one needed it too.

I share this so that others doubt a little more before working through all the aforementioned steps :wink: