Rpi-update definitely fixes my USB DAC issues

I posted this is a fix but I wasn’t sure because I’d only tried it the once. However, this weekend I went away so turned off the Raspberry Pi. Came back and it wouldn’t boot up again. I’d had a new class 10 SD card delivered (was using 4 previously) so figured I’d start again.

Installed, mounted and tried to play a flac file. I had the annoying pops and clicks that I had last time I installed. So despite some posts suggesting otherwise, I formatted and re-installed, then ran the following code after first boot:

sudo apt-get update
sudo apt-get install binutils
sudo apt-get install rpi-update
sudo rpi-update

Mounted, played flac files. Works perfectly. So it’s definitely fixes things for me - I’m using UD110v2 DAC.

I tried this fix (thanks for posting), and got the following after the third command line (sudo apt-get install rpi-update):

I’m a total beginner with Linux, so can’t tell if this is normal/to be expected…


I had the same problem and the fix is here: github.com/Hexxeh/rpi-update

I’ve simply run
sudo wget goo.gl/1BOfJ -O /usr/bin/rpi-update && sudo chmod +x /usr/bin/rpi-update

and then

sudo rpi-update

Rpi update is included.
Install binutils firts

sudo apt-get install binutils
sudo rpi-update

Thanks for the replies.

When I run
sudo apt-get install binutils

This happens:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package binutils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘binutils’ has no installation cadidate

Did you do sudo apt-get update first?

Thanks Michelangelo, that did it. I hope it solves the click and pop problem. Any other advice much appreciated!