RPI disable HDMI-CEC


I’am using a raspberry pi with a receiver. Audio goes over HDMI to the receiver. My TV has support for HDMI CEC, but somehow there’s two things that go wrong with it.

When the TV is turned off, and I boot up Volumio on the PI, the TV turns on and switches channel from HDMI 1 to HDMI 2 (which has no input). That is very annoying because I keep changing channels and need to turn of the TV again and again. Because I keeps flipping on every -X. I would like to disable HDMI-CEC on the RPI-side.

When I turn switch the powersocket for the receiver and the USB port on which the RPI is powered. In the first boot sequence there is no audio over HDMI. After a full reboot, the HDMI audio does turns on. This could be some timing issue when the receiver it not yet fully powered after first being switched off. How could I force HDMI audio output? Even when there’s no ‘live’ connection yet in the first seconds. Like what happens in the first seconds in this discribed situation…

Any advise is welcome :slight_smile:


Hi Beninho,

there are a couple of reasons coming to my mind that would cause problems like yours. Since you unfortunately didn’t exactly tell the details of your setup you need to decide yourself if any of the following might apply.

Turning off CEC may help but might not necessarily be your solution. You could first try adding “hdmi_ignore_cec_init=1” to the config.txt . This prevents the RPi from sending the initial active source message over CEC. This might be enough.
On the other hand some TVs (like mine :angry: ) try to be smart and switch sources whenever they detect a new signal on any port. That can of course only occur if you connect the RPi to a TV and from there to your amp. I’m curious if anybody has a suggestion for this case, but I think, fiddeling with the Pi’s settings or even turning off CEC will not help at all – you’re simply out of luck.

If you are lucky adding just another line to the config.txt will do. “hdmi_force_hotplug=1” will make the RPi always send signals to HDMI, even if it does not detect any receiver on the other end.

I hope that helps.
Best regards

Hi Fretzke,

My setup is:

Samsung BP37EO TV is connected with the HDMI output (ARC) from the Marantz NR1402.

RPI-zero with usb-wifi is connected to HDMI-2 input of Marantz.
HTPC is connected to HDMI-1 input of the Marantz.

  1. I’ve added hdmi_ignore_cec_init=1 to the config file. Just to make it clear. There is 1 input in my TV, and that is the HDMI1 input that came from the Marantz. Your sollution worked. Thanks. :slight_smile:

  2. Set the hdmi_force_hotplug=1. That did not work. while there is video output, there’s no audio.

In situation 2, there’s a powersocket with multiple outputs. like the on in the image. . Thats makes the Pi and the receiver boot at the same time…

Any suggestions?


Any other suggestions?

I’m glad at least the first part worked. :slight_smile:

Your seccond problem does sound kinda weird. If HDMI is sending a video signal it should always send audio as well imho. :confused: Maybe this is an issue of the audio connection being out of sync? You could try playing with the audio settings like sample rate etc. to narrow it down.