RPi 4 Volumio will not boot

Hello everyone,

I’ve just gotten a RPi 4 2GB to use with Volumio. However, no matter what I try, Volumio will not boot. To be more precise, the ACT light (green) flashes a few times when power is connected but will then be off completely and nothing will happen at all, while the red light stays on to indicate power.

Hardware specs:
Raspberry Pi 4 Model B - 2GB
Sandisk Ultra 64GB A1 Micro SDXC
Official Raspberry Pi 15.3W USB-C Power Supply

Images tried:
These two, when connected to a display via HDMI, will send a black screen as the output indefinitely.

These two, connected the same way, will show the boot loader screen and give out the following errors: recover4.elf not found, recovery.elf not found, start4.elf not found

All of the images were flashed to the micro sd-card multiple times each, using BalenaEtcher, RPi imager, Rufus and Apple Pi Baker

The micro sd-card was pre-formatted using SD formatter (to exFAT) and MiniTool Partition Wizard (to FAT32) but also left untouched between flashes with no prior formatting.

They were flashed using 3 different computers, (2 Windows 10 machines and 1 Mac running Catalina), with a combination of internal SD card readers using the adapter included with the card, as well a usb sd-card reader.

The micro-sd card was tested with H2testw and confirmed to be working. The RPi 4 was confirmed to be working by successfully booting into RPi OS and MoodeAudio multiple times.

The images were downloaded using the 3 different computers and were redownloaded multiple times.

Boot was tried with HDMI connected and with it disconnected.

The wifi hotspot never shows up and connecting via ethernet is also unsuccessful.

No USB was connected to the RPi while booting.

So finally, there seems to be zero activity when trying to boot volumio. If anyone has any idea how I can fix this it would be amazing. Thank you!


I tried installing the volumio buster beta 3.015-2021-01-03 and it worked.

I’m guessing the 2.779 and 2.698 that I tried didn’t work just because they’re too old. But there has to be some issue with the 2.873 and 2.861 releases. Tried the one before that as well (2.853) to no success (displayed black screen only).

I guess I will be running beta 3.015 for now until a solution is found. Oh and my board is a rev 1.4 if that helps. Thanks!


summary of images tried:

beta 3.015-2021-01-03 (working)
2.873-2021-02-19 (displays black screen & no activity)
2.861-2020-12-22 (displays black screen & no activity)
2-853-2020-11-20 (displays black screen & no activity)
2.852-2020-11-11 (displays black screen & no activity)
2.834-2020-09-24 (displays black screen & no activity)
2.799-2020-07-16 (displays black screen & no activity)
2.779-2020-06-08 (displays boot loader screen & error)
2.698-2020-01-16 (displays boot loader screen & error)
2.609-2019-09-11 (displays boot loader screen & error)

did you try touch display plugin? it seems your looking for a hdmi image…
volumio is headless so if you want to see it you could use any browser
and type your ip in the browser or try the standaard volumio.local

Hey thanks for the reply!

I’m only using the HDMI to confirm if it’s working or not, when it does work you see the processes happening and it eventually opens up the command line terminal. This doesn’t happen on the non working ones I mentioned and the volumio.local web UI doesn’t show up either since nothing happens and it’s not actually booting.

uhm i’m already skipped all the 2.xx versions it crashes my network but all that
i have runned on rpi4 4 gig would run…

i’m only run 3.xx versions at the moment.

there were cert problems but not a boot problem… strange…
and for hdmi you need the touch display plugin to see the volumio web UI on a screen.

Yea it’s definitely strange that this only happens with volumio for me, its unfortunate. I was not expecting so many problems, got the RPi specifically to make a volumio streamer. While the beta 3.015 boots, it has problems of its own (understandably). UPnP doesn’t work and when connecting my usb dac it keeps giving ALSA “broken pipe” and “failed to open audio output” errors so there’s no sound. I might just be unlucky.

As for the hdmi, it wasn’t being used to see the web UI. Another computer was used with a browser and volumio.local. HDMI was only being used to see if the command line processes on initial boot would show up or not, to indicate if any process is happening at all.

Out of curiosity do you know which RPi 4 hardware revision you have?

same as yours only the 4 gb version… i got 2 working one on 3.015
but i have a back up with the 3.10 all are beta but run oke… for what i use
my dac is a dragon fly
but how do you burn your images? rpi imager or with balena ether?
pre format a sd is not needed just burn the image…

I’ve tried both pi imager and balena to burn the images with pre formatting and without. Every other OS ive tried worked on the first try (RPi OS, moodeaudio, runeaudio, ropieee), my dac is inside an integrated amp (topping MX3). It works for a few minutes and then can’t seem to negotiate the parameters or something, on the display you see it switch from 48 to 44.1 or 96 then back to 48 and nothing plays.

So yea so far volumio still won’t boot and my dac seems to have issues with raspberry pi hardware.

The solution to my booting problem was to follow this post Raspberry Pi 4 8GB - cannot install - "This board requires newer software" - #7 by oXo, where basically you have to:

  1. Flash a working (or latest) image of Raspberry Pi OS onto your micro sd card.
  2. Go into the boot partition on the sd card with your file explorer on any computer.
  3. Copy all the .elf and .dat files you see and save them onto your computer.
  4. Flash the Volumio image you want to use back onto the micro sd card.
  5. Replace Volumio’s .elf and .dat files with the ones you saved previously.

The solution to my USB DAC connectivity issues was fixed by using a simple 4 port USB A hub (didn’t need to be powered separately).

1 Like