RPi 4 + Spotify plugin issues (SOLVED)

Im trying to get my newly installed Volumio to do spotify connect but i seem to run in to all kinds of problems.

  1. Installing Spotify Plugin seems to work but it wont being enabled. Giving this message:
spop Plugin
This plugin is failing to start. Please install updated version, or contact plugin developer
  1. Volumio Spotify Connect2 plugin wont install (but gets installed…isch)…
    The installation stalls at 70%

Then says: Plugin installation script failed!! An error occurred while installing the plugin Error

  1. Both plugins can be seen in the “installed plugins” list

3.1 The Spotify-plugin cant be enabled, see first issue.
3.2 Volumio Spotify Connect2 can be enabled, but doesnt work.

When i try to update the Spotify connect settings i get this:

Spotify Connect
Unable to update config: Error: Command failed: /usr/bin/sudo /bin/systemctl restart volspotconnect2.service Failed to restart volspotconnect2.service: Unit volspotconnect2.service not found.

I’ve tried reinstall the whole system, reboot etc.

Please search the forum for Spotify problem…
But how do you install plugins?
Did you change default Volumio password?

Yes. I already searched (might have missed anything relevant)

Default everything.
Installed via the Volumio GUI

What @balbuze is referring to is the massive current thread on this very issue. In short, the native plugin is not working due to expired elements but is being rewritten. Spotify Connect plugin is fine.

Thanks, maybe I didn’t search for that as I was mainly looking for the Spotify connect functionality. I’d be fine without Spotify in the Volumio interface. I’m using Qobuz but I need Spotify connect for the WAF

Case closed.
I located the issue. For some reason I haven’t figured out yet, my network is blocking Volumio from fetching the files need from GitHub. I successfully installed the plug-in via my neighbours network and will start troubleshooting my firewalls and DNS instead.