RP 3 + Touchdisplay : no touch function

I kindly like to ask for your help.

I tried to build a touchscreen music player out of a PI3, Volumio 2.185 and a odroid 7" touchscreen.
The touchscreen plugin installation worked fine and it boots right into the UI.

Unfortunately i encountered a few problems.

  1. The touch function does not work.
    I only see the UI with a pointer in the middle of the screen. No matter where i press on the screen it does not react.
    Connecting a mouse i can move the pointer and use the UI. So it seems it has something to do with the touchfunction.

  2. The UI is only displayed on the left 3/4s of the screen. The remaining 1/4 remains un-used.

  3. on the leftmost side there is a small pink stripe 2 pixels wide from top to bottom.

Any help would be greatly appreciated.

i sorted out the screen size problem by adding the right resolution (800x480) to the config.txt

unfortunately the non working touch function still is not solved. Any ideas ?
( i tried adding max_usb_current=1 to the config.txt but that did not work)

I believe that the “Yellow Flash” symbol on the screen is a warning of low power - I wonder if this could be the cause of your issues?

My very limited experience of Linux is that its not really “Plug n Play” you need to be a full up computer geek to get it going - so good luck.

BTW I also ordered the same screen (with Capacitive touch version) - which version do you have Resistive or Capacitive touch (it looks like a Capacitative touch type)?

Once the Panel arrives I’ll give it to Jarek who works with me and I’m sure we will get it going…

Thanks for the suggestion, i will try a bigger power supply.

the screen is a Odroid vu7 with capacitive touchscreen.