Rivo was recognized during setup, but no playback and now app or local search can't even find it


I got my Rivo, set it up and connected it via ethernet cable and aes cable to my dac. It showed up immediately. I logged into my existing account, and it showed up with all my playlists. tried to play a track, but nothing happened. I then tried refreshing the app, but then it could no longer find the Rivo. I’ve now tried discunnecting a reconnecting everything, then leaving the dac disconnected while starting it back up, tried accessing through volumio.local, nothing is working. I’ve sent a message to Marco, who had initially reassured me that I would be able to simply login with my existing account hoping to hear back soon. But wanted to ask here for some advice.

Please help!

John in the US

@DED @Darmur

Dear John,

here it is Davide from tech support

Since you are a Rivo owner, you are entitled of dedicated technical support.
An email has just been sent to your address, please follow up on that for further help.


Hi Davide,

Just sent you a return email. Still nothing after taking the steps necessary for factory reset via usb drive. Thanks.

After a few tries with factory reset via usb drive, Rivo’s working great. Thanks to Davide! :+1: