Responsiveness with 27K songs....

I’m not new to sound, have only built four Pi projects (others not audio related), but am new to Volumio.

I’ve pointed a new Pi 3 with HifiBerry Digi+ (latest Volumio) at a NAS with around 27K flac files on it. It indexes them in about 35 minutes. And it works, but slowly. 30 seconds to search for a song, 10 seconds to respond to “play” or “pause” commands. Is this expected with that library?


Marc in Texas.

Mine is about half that size, but it takes less than a second to search. Play is almost instantaneous, unless my device(phone or tablet) went to sleep and I need to refresh the browser. Is it still a pretty new installation? I remember reading it goes slow at first while it deals with cover art.


My library is about 60k songs and I find search almost unusable on the web ui. I’ve always considered the way the files are served to be my main issue. I use a 3 year old chromebox with a 2tb USB HDD attached as a file server.
It always takes about 5 seconds for a song to start playing at the start of a listening session, again this is the HDD (can hear it spinning up).
Once playing playback controls are fast and responsive, either using the web ui, mobile app or hardware buttons attached via gpio.

Have you tried using a generic MPD application on your phone for playback? I use this one … ipone.malp and it’s much faster to search the library

Sent from my SM-N950F using Tapatalk

The location for this unit has no Internet, so I hope it’s not trying too hard to update art. All of the files and folders I put on the drive already have art; is there a switch to tell it not to bother?

Yes, I’ve been wondering if there’s a better way to serve them.

The hard drive should stay spinning for this install, unless we shut down for an hour or more. Once a song is going, button response is better, but still often a 1-2 second lag.

Volumio is using MPD under the covers, right? I was wondering if there was someway to offload the database/index/search functions from the MPD functions…

could it be that the headless setup is inherently less responsive than the traditional standalone setup?
as posted elsewhere, in my case the best would be a classic PC setup (computer, screen, usb-attached mouse/keyboard), where my rasberry pi is acting the “old” computer.
being able to choose between standalone and headless would be just great to me.

I would of thought a dedicated NAS with everything connected via cable is the best way to go. I’ve never tried plugging the HDD straight in to the Pi.

Yeah MPD is the software on which Volumio is based.

One thing that has been discussed on a few occasions recently is the ability to use a NAS or the PC where your music files are located as a proxy database MPD does support this feature but if you try and set it up on Volumio it breaks things. I keep meaning to have a play around with this again.
I installed MPD on my chromebox and it does work well if you install MPD on raspbian and use ympd for the web ui. But the feature trade off for me wasn’t worth it.

There have been discussions regarding the theoretical max library size, I don’t think anyone has ever given a definitive answer. I imagine it depends on a lot of different individual factors.

As for your issue, it’s always worth doing a fresh install, try different SD cards and see if it improves. And have a look at the logs (search the forum for info on where they are located)

Sent from my SM-N950F using Tapatalk

I have a music library of around 100K tracks (all at least Flac 16) They are stored on a NAS (a high spec FreeNAS). Volumio on a raspberry pi 2B. All hard wired. I never have any delays on listening to the track, play and stop. However search (or even browsing) is almost unusable. The browsing could be improved with a letter bar but searching would probably require a faster index search engine.

Sent from my iPhone using Tapatalk

so how do you deal with it?
I haven’t devised a strategy yet. I can live without the search function, but being unable to browse makes it pretty useless.
I must say, even with a win10 PC the “music” folder on the nas is loaded way more slowly than with a usb connection.
I agree that a letter bar would be very useful (I always type the first letter of the artist to jump there when I use the PC)

To clarify browsing is responsive, but the huge list makes it a chore to browse to the Later letters as there is no way to quick jump like with a letter bar or accelerated scrolling

Sent from my iPhone using Tapatalk

This is kind of down the path I was thinking. The library will be pretty static once I finish ripping FLAC files and eliminating duplicates.

The Pi arrangement with WiFiBerry is proving very good results as a transport, I’d like to move the data management away from it. Seems like I’d like to index the library on a laptop, have the interface there, then use some back-end connection to tell MPC on the Pi to “play this now”. I’m not married to Volumio for this, but respect the fact that people are working on it and it looks and works well for more modest libraries.

I may be playing around with this next:


I have similar difficulties to browse and search some tracks in my music library; I have 4K songs and a raspberry pi 3 audiophonics. The tracks are stocked on a hard disk directly connected via usb to the raspberry pi.
However the harddisk is feed with the raspberry so maybe there will not enough ressources to index and browse music fastly.

One more thing, the whole music seems to be indexed but when I want to browse in my library i have only some folders possible to browse and not the total.

where does your hard disk get the power? if from the Pi’s usb, it’s not good.

Hi all,
Why not install minimserver on your nas or pc and use volumio as a upnp renderer. For control point - Linn Kazoo is quite good - which is free and supports both ios and android. No problem for browsing and search large libraries. Give it a try

Yeah the hard disk is feed just with the pi’s usb?

It is not good yeah but I don’t succeed to add a network disk with Volumio. I have tested everything, different ip adress, different paths for the folders, checked the share options…In vain!