Repeated rescans not picking up some changes


My enjoyment in using Volumio motivated me to clean up my music library. After a fair amount of effort, everything has been correctly tagged, cleaned up and the files have been named in a consistent manner (thank you mp3tag!).

Update / Rescan aren’t picking up a lot of the changes even after repeated attempts and letting them run for many hours. Oddly, many changes are seen and reflected in my Volumio library.

I’ve gone as far as renaming my music directory, removing the nas from Volumio etc. The only thing I haven’t done is a clean re-install of volumio. I’m hoping I won’t have to do that. Is there any command line option or anything to force a recursive and systematic rescan of the library?



I just experience the same problem at the moment. I’m testing Volumio on an USB on an older notebook for testing. Being new to Linux operating system if found out that there is a difference between “Beyond The Black” and “Beyond the Black” in sorting. Like eforer I cleaned up the tagging to “Beyond The Black” as artist and also as album artist. Unfortunately Volumio does not seem to update the library upon updar or rescan. Afterwards the library shows the old and the new album artists.

What’s the trick here? Coming over from Sonos I never experienced such library issues. Rescanning the library is usually fast and without problems.

Edit: I think I have an idea… I use a Synology NAS and I have a user called “Sonos” who has only read permission to the shared folder. If I mount with another user that has read and write permissions my problem seems to be solved. I copied one album in another folder. If I change for example part of the album to lower case and update the Volumio library it’s update. If I change back and update again, it’s also ok.
That brings me to question why Volumio needs a user with write permissions?

Edit 2: Ok, false alarm. For my test folder with only 2 albums changes are updated almost instantly even with the read only user So back to the initial phenomen.

I see similar issues with Volumio on a Raspberry Pi.
Every now and then I’ll get an edit like that which won’t update to the GUI.
Or an album cover image that won’t show up or update.
I click the storage (local USB drive) action menu and choose Update, I go to the specific folder and do the same, I go to the Settings menu, Sources and do the same. It can take a while I think, there must be other background processing tasks going on and it makes the updates in the GUI delay.
Usually if I go off to lunch or something, it will have finally updated when I return.
But it sounds like you had a more local issue with the share permissions on your NAS.

Well, I think share permission was not the problem. Maybe it’s the same as you experienced.
I added my usual Sonos music folder and another with misc music, with roughly 56k tracks altogether. I merged two separate folders “CD 1” and “CD 2” to one folder, Volumio correctly reduced the number of albums by one during the update.

Hi there!

I’m facing exactly the same issues like eforer with my USB data. I’ve edited AlbumArtists with mp3tag, and now they are shown twice in the library. With the old and new artist names.
Furthermore, I’ve deleted some albums/artists completely, but they are still shown.

Tried all sorts of updates, and have even run a factory setting reset, but the old artists remain.