I am trying to rclone to work with Volumio. When I mount drive Volumio cant see it. But I see files in /mnt/INTERNAL/Music?

Any ideas?

I was facing the exact same problem as you.
I suppose that Volumio expects some specific user rights when using the INTERNAL folder.

Try using the “–allow-other” flag while mounting your rclone drive. This worked for me.