Raspi2 & DAC+ not working at all

Hi there, first of all state that i’m totally newbie in the raspberry world.

I just purchased a DAC+ (RCA out) to plug on a brand new Rasp 2 (with the nice looking clear case)

I thought it would work “out of the box”, please read this as: plug them together, install volumioruneaudio* (“whatever”), enjoy the music on NAS.

It did not.

I downloaded the image if hifiberry with the 1Khz tone and works so far, so i must assume that is something with the “versions-kernels-strange’cpus” that is out of my knowledge.

Is there any way to make it work on that purpose without too many trouble?

My entire idea is to use it as a music player with Volumio (from web remote or mobile app) via wifi (the adaptor is a TP link Nano USB)

On the other hand, any other distro that i tried like openelec, noobs, raspbian… works flawlessly. Even Volumio 1.55 without the DAC and the wifi dongle works…

Thanks in advance,


This combination (Raspberry Pi 2 & DAC+) works for me, although my music is on a USB stick rather than NAS.

Could you be a bit more specific about what works and what doesn’t. Can you connect to the web interface (volumio.local/)? If so, is your music listed on the browse tab? Have you set the playback device in the settings menu?

Not working at all = Don’t even starts with the DAC & wifi dongle plugged in.

I solved it switching to RuneAudio 0.3 beta (a nightly build that is purposely for Pi 2) and it works wonders. So i assume there is some issue with the armv7 processors compilation or whatever. But i’ll be curious to try a Volumio release when it’s proved that works.