Raspberry Py boot without eth0


I noticed the latest release of Volumio (1.51) does not configure wlan0 though I have a dongle attached. The dongle works in OpenELEC just fine, so I’m guessing it’s not a driver issue.

If I boot the rpi with eth0 connected, I can configure the wlan, which is nice. However, the device spends endless amounts of time on subsequent boots trying to configure eth0.

This might not be a bug, but I hope it gets some development love :slight_smile:


wlan0 should be configurable via the web interface
Menu --> Network --> Wireless Connection

There you insert the SSID and Password of your wireless connection.

For eth0 theres a timeout before linux stops looking for DHCP you could decrease the amount of seconds before the timeout kicks in.
But i cant find where volumio has this configured…
Its either on of these, or its completely diferent…


Or you could disable eth0 completely in

sudo nano /etc/network/interfaces

There you’ll see your network configuration

auto eth0
iface eth0 inet dhcp

Change to:

#auto eth0
#iface eth0 inet dhcp

This way your wired connection is disabled, and will only be re-enabled when you remove the #