Raspberry PIs out of sync while using airplay

I have two Raspberry Pi devices running the latest version of Volumio. One uses HiFi Berry and the other Schiit Modi. I have tried with both iTunes and MusicBee running the RemoteSpeaker plugin for Airplay.

No matter what music player I use, one device seems to be about a full second ahead of the other. I’m not even sure where to begin. Any suggestions? I have tried resetting then and syncing their clocks to a local NTP server.

I have been successful with a real time clock

Got it. In the Volumio web directory, there is a PHP file which has the shairport command that is run to launch it (the player_wrk.php file in the /var/www/command directory). I had to edit the command parameters to play with the buffer (done via the -b parameter). On the player that used HiFi Berry, the buffer is set to 440. On the player that uses the Schiit Modi, I set the buffer to 295. I will need to do some further testing, but they seem pretty in sync to me now.

Hope that helps someone else in the future.