Raspberry Pi3B version 2.882


I tried to upgrade to version 2.882 and the upgrade failed - Pi3B with touch screen. Previous versions all worked well.

Re-flashed the SSD with the new version and that works - except the touch screen is not responsive and displays a volumio login. Touch screen plugin installed. Any ideas?


try to switch it on and off it should be just work…

Thanks for the prompt reply. I tried that - no joy.

try re-install ?

Yes, I think that has to be the next step. I’ll try that later and see what happens. Thanks.

Could you post a system log – it might be there is a conflict of libraries.

See - Cannot install build-essential package for details…

System log submitted. I think! Not an expert. Reference is

The touch screen is active - display is blank (white). It dims after the usual timeout and reactivates (blank screen) after a “touch”.

Hope that helps.

Did you have the chance to uninstall and re-install the Touch Display plugin?

If that should not solve the issue please connect to Volumio via SSH and post the results of

chromium-browser version


systemctl status -l volumio-kiosk.service

Thanks for the suggestions.

I have tried reinstalling the plugin - no change.
I have enabled SSH - and then reached the limit of my competence! Sorry :frowning: No information visible re chromium or systemct1. Perhaps I need to do something else?

Perhaps the best approach would be for me to start from the beginning and reflash the SSD and install the plugin. If there’s a problem after that I suspect it must be with the Volumio build or the Plugin. In that case I would expect others who have upgraded to have the same problem?

i would say give a other version of volumio a try …think that’s the best option right now.
but wait maybe ash has a anwser…

I am assuming you were able to connect via a terminal to your device after enabling SSH? Then it is just a case of typing out those commands and hitting enter to see a spew of text :wink:

Yes, that would be fine I think - nothing significant in the latest version that I cant do without!

Where can I download the previous version from?

Ah, I see. I’ll have a go later today. At least this is keeping me busy! Thanks.

In case you should decide to flash an older version here you find a link to 2.873.

Many thanks for your help. I have reinstalled using 2.873 and the touch screen plugin - all working now! I’ll wait while before trying any new upgrades.


just skip that one maybe it’s fixed in the next releases…we will see.
most of the update where for x86 you even could try the 3.xx then your things are up to date.
instead on a very old release (jessie).