Raspberry Pi3 HDMI Touch Screen

Hi everyone
I bought a touch screen TFT Touch Screen Kuman 3.5 Inch 1920*1080 and I would like to be able to launch it with volumio (perfect for volumio).
I need help
The first thing I need is not to stay on the login screen, but to run web browser localhost: 3000 (as I have read)
The second activate the touchscreen with the drivers that brings the screen (LCD-Show)

Otherwise everything ok


Alguna idea?

  1. Install the touchscreen plugin, this will show the UI on HDMI
  2. Connect this little screen via HDMI

Thank you very much Michelangelo

With the plugin now it is seen by HDMI perfectly but the touch does not work.

In another test that I performed to rule out the problem of the screen, I installed Raspbian strech and everything works correctly.

I have tried to install the drivers and to modify the config.txt adding what initially does not have but I do not manage to make the touch work.

After many attempts and tests I have found the solution, I have managed to make the tactile work well. I put the step by step of everything I’ve done in case someone helps

1.- Format SD Card with “SD Formatter”
2.- Record image of Volumio in SD with Win32DiskImager
3.- Once started, activate Volumio SSH at http: //volumio.local/dev
4.- Enter by ssh
5.- Update repository
sudo apt-get update

6.- Install the keyboard configuration
sudo apt-get install keyboard-configuration

7.- Perform the installation of the Volumio Touch-Screen plugin

/ ************ THE SCREEN WORKS BUT THE TACTILE DOES NOT ********************** /

8.- Make a copy of the files config.txt and cmdline.txt that are in the boot

9.- Perform the installation of the LCD-show screen drivers (cloning from the repository)
Follow instructions from github.com/goodtft/LCD-show

sudo rm -rf LCD-show
git clone github.com/goodtft/LCD-show.git
chmod -R 755 LCD-show
cd LCD-show /

sudo ./MPI3508_810_540-show

After doing this the configuration files config.txt and cmdline.txt will be replaced
10.- Rename the current files config.txt and cmdline.txt to config_drivers.txt and cmdline_drivers.txt
11.- Restore the original files config.txt and cmdline.txt
12.- Add to the config.txt the specific configuration after installing the drivers (config_drivers.txt)
hdmi_drive = 2

hdmi_force_hotplug = 1

hdmi_group = 2

hdmi_mode = 87

hdmi_cvt 810 540 60 6 0 0 0

dtoverlay = ads7846, cs = 1, penirq = 25, penirq_pull = 2, speed = 50000, keep_vref_on = 0, swapxy = 0, pmax = 255, xohms = 150, xmin = 200, xmax = 3900, ymin = 200, ymax = 3900

13.- If you need to turn the screen add display_rotate = 1 in the config.txt


14.- Purge the default calibration of the screen
apt-get purge xserver-xorg-input-all xserver-xorg-input-libinput
apt-get install xserver-xorg-input-evdev

add to config.txt
dtparam = spi = on

15.- Install the screen calibrator
apt-get install xinput-calibrator

16.- Carry out the calibration of the touch
sudo DISPLAY =: 0 xinput_calibrator

/ ********** EVERYTHING WORKING PERFECTLY ***************** /

I would like to attach the same display.
Does somebody know if it works with Alllo Boss ?

(I will never understand why they not put a pinning diagram and a “what is used” to the parts.)

i tried this like quashaza wrote with a 3.5 kuman - GPIO-Display and had to change it a bit.
so i will write it down for others and me for later use:

first get ssh to work (volumio.local/dev/)
than connected to ssh (pw and user: volumio) do the following:

sudo apt-get update

than get the lcd-files:

git clone https://github.com/goodtft/LCD-show.git cd LCD-show

sudo mkdir /etc/X11/xorg.conf.d sudo mkdir /share/etc/X11/xorg.conf.d sudo cp ./usr/tft35a-overlay.dtb /boot/overlays/ sudo cp ./usr/tft35a-overlay.dtb /boot/overlays/tft35a.dtbo sudo cp -rf ./usr/99-calibration.conf-35 /etc/X11/xorg.conf.d/99-calibration.conf

add following to /boot/config.cfg

dtparam=spi=on dtoverlay=tft35a

then execute

sudo dpkg --configure -a sudo apt install keyboard-configuration

now restart (sudo reboot)
and install the Touch Display Plugin via the webbrowser-interface (volumio.local)
activate the plugin

connect again to volumio via ssh, then
create a file called “99-fbturbo.conf”

sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf

and fill it with the following lines:

[code] Section “Device”
Identifier “Allwinner A10/A13 FBDEV”
Driver “fbturbo”
Option “fbdev” “/dev/fb1”

  Option "SwapbuffersWait" "true"


save this and reboot once more again
– the display should work now with touchscreen, but the x-axis are inverted –

change the following line in the /boot/config.txt



dtoverlay=tft35a, cs = 1, penirq = 25, penirq_pull = 2, speed = 50000, keep_vref_on = 0, swapxy = 0, pmax = 255, xohms = 150, xmin = 0, xmax = 65535, ymin = 0, ymax = 65535

if it doesnt work now, after a restart you can get your own xmin/max and ymin/max doing the following:

apt-get purge xserver-xorg-input-all xserver-xorg-input-libinput apt-get install xserver-xorg-input-evdev sudo apt-get install xinput-calibrator
this resets the xserver-config and installs the needed tool xinput-calibrator
starting this tool with following line:

sudo DISPLAY=:0 xinput_calibrator

this will result in a message like this:

Calibrating EVDEV driver for "ADS7846 Touchscreen" id=6 current calibration values (from XInput): min_x=3936, max_x=227 and min_y=268, max_y=3880
the min and max settings go to the config.txt
and now it should work properly!

Seems like an awful lot to consider.
I was experiencing problems with mit Touchscreen from Liliput to put it in my car. i tried several projects to get it to work the way i wanted. On my way, i found this thread raspberrypi.org/forums/view … 91&t=78805 I finally got my display working fine on Jessie, but it still doesn’t work in Kodi.
My first working Software is Volumio because it’s based on Jessie. Once i had figured out the calibration in Jessie i was able to do some easy steps to make it happen in Volumio, without going throucgh all you have done here.

First in installed the plugin, then i used this after enabling ssh

sudo apt-get install xserver-xorg-input-evdev xinput-calibrator -y sudo mv /usr/share/X11/xorg.conf.d/10-evdev.conf /usr/share/X11/xorg.conf.d/45-evdev.conf

after that i plugged in my Controller, edited the
/etc/X11/xorg.conf.d/99-calibration.conf with my code i learned from calibration in Jessie

Section "InputClass" Identifier "calibration" MatchProduct "eGalax Inc. USB TouchController" Option "Calibration" "3959 125 402 3707" Option "SwapAxes" "1" Option "InvertX" "1" Option "InvertY" "1" EndSection
and rebooted the system

that’s all and it works fine. I will go for Volumio for now. Maybe later on look out for a solution for Kodi, or even use emteria…