Raspberry Pi Zero + Justboom Dac Zero = no sound

Raspberry Pi Zero + Justboom Dac Zero = no sound

I have followed the guide on justboom.co/software/config … h-volumio/

But I can’t get any sound, my brother also tried installing on his identical setup and he gets no sound either.

Any tips ?

I’ve been having the same problem over the last week or so. I know it’s not the hardware since it works fine with PiMusicBox. I would really like to get the multiroom support that Volumio with the snapcast plugin allows, which is why I’ve been trying Volumio.

Which Volumio version are you running please?
What is selected as i2S DAC in Playback option UI Panel?

Then can you activate ssh (in VOLUMIO_IP/dev) and connect over ssh with another machine (ssh volumio@VOLUMIO_IP) and type:cat /boot/config.txt aplay -land report output.

I’m running the latest pi version. 246?
I have ‘Justboom DAC boards’ selected for model and playback.

volumio@volumio:~$ cat /boot/config.txt
initramfs volumio.initrd

Volumio i2s setting below: do not alter


volumio@volumio:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

If it helps at all, the working pimusicbox install has this line in config.txt instead:



If I change that last line to match, the sound works but the volume is cranked all the way up and won’t go down.

Yes indeed, that’s the issue: for some reason, justboom overlays names changed recently (August 5th), and should be adapted until a new release version with the changes is available. (some recent pre-release beta versions have the changes already).
It should indeed be dtoverlay=justboom-dac in your case (if using JustBoom DAC Boards).

About volume tuning, you may want to try to apply software mixer setting in same panel.

I think the mixer control was set to none before. I have a narrow window where I can work on this each night because it plays lullabies for the kids when they go to bed.

Setting the mixer to software gave me a red error box that alsa couldn’t open softvolume or something to that extent. HW with digital control seems to work, but the interface is kind of slow and seems to bounce a lot.

I do not have this DAC, so can’t help more with specific settings I’m afraid.

However did you let the Pi settle for long-enough (about 8mn) at very-first boot after imaging SD?
Not taking care of that can lead to many sorts of problems later (like UI bounces) as Volumio is not properly initialized.
Please check doc link in signature.

If problems persist after a new SD image and long first boot, you may send log information for review, using IP_ADDRESS/dev page right after issues happen.

I thought I had given it a long time after boot before I did anything with it, but it’s hard to say for sure. It’s rebooting on me when I try to scroll through albums (~700) or artists (~500) so I’ll try a fresh load and see if it behaves better.

Yes do a fresh install following guidelines first and check if problem persists.

Now, if it comes back, you are most probably talking about a different problem than the original DAC support; so to keep things focused, you may want to search for another topic now. This other one on library indexing issues may be more appropriate: you may test suggested beta versions which seem to address this.

Yeah, I don’t want to get too far off topic, and I think this is a separate issue. The no sound seems to be solved by manually editing the config file for now.

Thanks for the help.

Edit: I hit update library before I left for work and let it run all day. Everything seems to be fine now.