Raspberry Pi modelo B+

What you think about Raspberry Pi modelo B+?

Disappear connector P5 :open_mouth:

Hi Hardbit,

Apparently the P5 connector is integrated with the new 40 pin GPIO.

All is not lost, my friend!

Will it improve the audio quality using Volumio with the new B+ ?
Just read some news, and I can’t make up my mind…

:astonished: Look at this https://twitter.com/iq_audio/status/489085316423495680

Any reason why the volumio wouldn’t work on the b+?

Will we be seeing a “proper” version for the Raspberry Pi B+? I tried booting Volumio 1.4 on my model B, performing apt-get update and apt-get upgrade and neither the USB or Eternet ports are functional when the updated SD card is booted on the B+. Any ideas?

Raspberry Pi B+ works with RPi-DAC and RPi-DAC-RCA ! :smiley: :astonished:

Yes, I2S pins from P5 are gone. I2S is now on GPIO header, different pins.
DAC works with wires (modified PCB coming soon) and: KERNEL PATCH needed!
Just wires does not work.

BTW: If you try to enable the /etc/modules for HifiBerry or RPi-DAC - you system will hang if you play to I2S.
Without kernel patch (modified pinmux) it cannot work.

Best regards and happy B+ DAC listening.

quick and dirty way to get volumio running on a model b+:

head to raspberrypi.org/downloads/ and download latest noobs install.

open up the zip.
locate boot.tar in os/Raspbian.
extract bootcode.bin and kernel.
copy bootcode.bin and kernel to root of your existing volumio sd card.

follow up with:
sudo apt-get install binutils
sudo rpi-update
sudo reboot

you may have to reconfigure audio:
sudo lsmod | grep 2835
sudo amixer cset numid=3 #
;# == 0=auto, 1=analog, 2=HDMI

Have you actually tried this?
I get errors with apt-get install binutils and sudo amixer…

of course. fresh 1.4 install followed up with the info i posted.

could you post your errors?


Enjoy :wink:


I’ve tried loading the updated version of Volumio for the B+ but get a load of error messages as per the attached.

Any thoughts on what I’m doing wrong would be appreciated!


format your SD card, then try to flash it again.
Maybe something went wrong the first time.

Dear Every one,

B+ is now working fantastic, after some problems. I thank you all for the nice player and the sound quality B+ / volumio improved over the laptop windows 7.

I get the same notice of failure as on the photo (translogs), but although now it is working.

I had difficulties with static IP and could not connect my android tablet to volumio, so I changed to dynamic IP. After applying the WIFI settings and config -a it worked. First I tried OpenELEC and the WIFI dongle worked inmediately, it took much more time to let it work with volumio (dongle: ASUS N13).

Yesterday evening the B+ gave only audio via HDMI to my TV and no sound at my DDDAC. Also files on Volomio UI were playing, but no sound. After several rebootings and hours later, and changing several times between ALSO en L20, it finally worked under L20. At AlSO no sound via de DDDAC.

The MPD database is confusing, while not all music files are shown at browsing. Only a small part of the HHD (3TB) was shown. Tonight I discovered that using the search machine, much more music files came visible. This is the same situation when using a 8GB usb stick. At openElec I also can discover the network pc’s,(shared folders) but in VOLUMIO I cannot discover the other PC’s in the network. Somebody can inform me how this could be arranged?


Hi Paul,

What did you do to get past the error messages? Was it a reinstall of Volumio on the SD card?