Raspberry Pi connection problem

Hey hi hello,

Like most posters in this part of the forums, I am new to this. I have a Raspberry Pi 2 Model B 1GB. Luckily I managed successfully to install Volumio onto a SD - card and run it on my RPI. I can access Volumio through my webbrowser, but the problem is I can’t access it on every device. I am not quite sure how to fix this, I’ve been trying for a couple of hours already :p.

I think it has to do with my network set up which is as following:
Modem --> Router which connects the computer downstairs --> Router which connects the RPI and my computer upstairs.

So I connected the RPI with a wired Ethernet cable but it is only accessible with the computer which is connected to the same router. I would like to be able to also access it with my Android phone.

From your Android phone you have to enter the IP address of your pi. It won’t work with “volumio.local”

Ah ye sorry forgot to mention, it won’t do that either. It will not load on my phone, but it will not give any errors either…
I tried to access volumio on the computer downstairs, same story.

All device have to be on same local network. Not sure to understand but you use 2 routers ? Or one is used as a router and provides addresses and the other one is just used as a switch?

Yes, the second one is used as a switch.

Make sure you have dhcp disabled on the 2nd router. The preferred setup is to not use the wan port on the 2nd router, disable dhcp and all forms of routing.

I disabled the DHCP server on my swtich, still nothing. I read somewhere that setting a ‘static ip’ might help, not quite sure what it means but could that help? If so could you point me to a guide or something to help me out? :slight_smile:

Ok so I connected the RPi directly into the router and it worked. So there is still something wrong with the switch…I can’t really figure out what though