Raspberry Pi 4 Volumio Not Working Hot Spot Not Appearing on Wireless List

Volumio Information

Volumio Version:volumio-2.861-2020-12-22-pi
Hardware: Raspberry Pi 4

Volumio-2.806-2020-07-29-pi stopped working yesterday. I swapped out Volumio MicroSD card and put in Rasparian OS card and discovered that wasn’t working either.

Downloaded 2020-12-02-raspios-buster-armhf-full, formatted and flashed MicroSD card and got Raspberry Pi SBC going. Then fromated and flashed another card with volumio-2.861-2020-12-22-pi.img but unable to get Volumio running headless.

Volumio Hotspot does not appear in wireless network list, can’t ping IP address or load http://volumio.local/. I’ve fformated and flashed SD card several times but can’t get it running. I went through this process serveral weeks ago with Volumio-2.806-2020-07-29-pi and had no problems.

I’m out of ideas. Does anyone have any suggestions? Thanks

Paul Burkhardt

I’m also having trouble seeing, and also connecting, to the Hotspot on a fresh install. Sadly I only have a Pi Zero so I can’t connect via a cable. I believe it is a compatibility problem with my USB WiFi dongles but I know I got one of the three I tried in the past (with an old Volumio varient) to work fine. The only one of the three that even shows in my WiFi list but won’t connect (no valid IP)
As an aside I have checked all my Dongles in a windows PC and they all install and work perfectly. Having spent about 2 days faffing with Volumio (again) I am on the verge of abandoning it for Picoreplayer which installs and works great (with a very quick boot time) My only reason for sticking at it is the hardware buttons and volume rotary I have built in that I’d like to still use.
My advice is to download an old install, change wifi adaptors, or connect with a network cable. if none of those work, set fire to it. At least it’ll keep you warm.

1 Like

I’ve plugged in ethernet cable and checked Raspberry PI IP address from router and discovered there is none. It looks like Volumio is not booting at all so no ethernet/wifi hot spot.

Check downloaded image file MD5, bought a new 64 GB microSD card and loaded volumio-2.861-2020-12-22-pi image. Rebooted with new SD card, waited a considerable time but router showing Raspberry PI Mac address but no IP address and no Volumio hot spot.

Raspberry PI Boot loader is Sep 3 2020. I’ve no clue how to trouble shoot this!!

Reformated a new 64G SD card and flashed the 22/12/2020 image and Volumio now works on Raspberry PI4. I’m not sure what that was all about but suspect the SD card format and imaging. Thanks

I am a new Volumio user.

After flashing the latest (9/2/2021) release onto a 64 GB SD card, and booting this on my Raspberry Pi 4, I do see a login screen on my attached HDMI monitor. I can log in, using the credentials: volumio/volumio

However, no hotspot appears, nor does the IP address appear on my network when I make a wired connection.

This, of course, means that I cannot use Volumio at all. Can anyone help me to get this initial configuration running?

Thanks so much.

1 Like

try the touch plugin and you could get volumio on your hdmi output.

if your logged in with volumio / volumio you could use :

ip addr

to see your ip, use any browser in your network and type:

http://< your ip addres >

and enjoy your volumio…

Just FYI: I did receive a note from Volumio support, suggesting that I might have used a beta download. Sadly, I’m having this problem with the stable release, 2.907. If anyone has suggestions, I’d love to hear them. I can’t wait to get started with Volumio.

When logged in as volumio, ifconfig returns information about eth0 and lo, but wlan0 or wlan1 do not appear.

When I have a hardwired connection to the ethernet port, I am able to ping outside ip addresses from the Pi, suggesting that the network adapter is working, but volumio.local does not appear anywhere on my network.

Perhaps something in the startup should be enabling the wlanX? I dunno.

BTW: The WiFi is working properly on my Pi when booting with the standard release software.

When connected by ethernet, go to the appropriate IP address & setup your wifi from there … you may need to set the actual IP address (as seen from your router, for example) rather than using ‘volumio.local’.

Thanks for the show of support, dvo and chsims1. Without a wired network, the IP address is self-assigned. With a wired net (on my RPi 400 unit), I can get an IP address, but no wireless device appears.

The intended use is on a Pi Zero W (no hard ethernet). I did place the SD card with Volumio 2.907 into the SD slot on my Pi Zero, but that also fails to create a visible hot spot.

sofar i could find out the Rpi 400 does have wireless :
Dual-band (2.4GHz and 5.0GHz) IEEE 802.11b/g/n/ac wireless LAN

// https://www.raspberrypi.org/products/raspberry-pi-400/specifications/

I can get an IP address, but no wireless device appears.

Have you enabled and set up wifi from the UI settings on your RPi400? What exactly do you mean by “no wireless device appears”?

chsims1: When I open up my WiFi settings on my computer or phone, I do not see a volumio network. My understanding is that Volumio is supposed to create its own wireless network when it books.

When I say that no wireless device appears, I mean that when I log in to the Pi, and enter ifconfig, no wlan device appears. I believe that this is telling me that the OS doesn’t detect a wireless device.

dvo: Yes, I decided to bring up volumio for the first time on my RPi 400 because it does have a built-in wireless adapter, as well as a wired ethernet port. I had hoped that this would be the most reliable configuration from which to start.

Thank you both for trying to help here.

If Volumio doesn’t find a wired network, and doesn’t have details of a wifi connection then yes it will start a wireless hotpoint. In your case, your device will receive a dhcp address (as you point out) over the LAN. You then need to go to wireless settings and find your home wifi ssid or enter the details manually if hidden. Volumio will then set up a wifi connection for you … it’s details should be shown along with those for the wired connection (make sure you refresh, and give it sufficient time for the network settings to be changed. It may even be necessary to reboot).

I have the same problems with my Pi 400 :frowning:

Reread post #13 carefully.

I cannot get a WiFi Hotspot signal on Volumio installation, either with an Ethernet cable plugged in or without one. I have a new RPi 4B 2GB (so it has internal WiFi capability at 5 and 2.4 GHz), a new 64GB SD card, and have tried flashing with Belena Etcher and the RPi installation app. I’ve tried turning off the 5Gz wifi signal to leave the 2.4Ghz WiFi signal from my Eero router (connected to a Virgin 3.0 Hub in the UK). I currently do not have a screen for the RPi but the red light shows and yellow light flashes occasionally. When the Ethnernet cable is attached both green and yellow lights turn on but do not flash - so I guess there is a connection but no data exchange. I’m using the latest image version of Volumio and I’ve tried going back to a V2. I’ve tried the start up and flashing many times and no results. I’ve tried different SD cards. I’ve installed the Volumio app on both IoS and Android devices, but neither find the Volumio signal. I’ve tried adding the volumio.local and the IP address in a Firefox browse but it times out. I’ve read the github Quick Start Guide and have trawled the chatrooms but nothing I’ve tried works.
After all this, I still have no way of finding the Volumio hotspot, so cannot proceed with the set up.
Am a complete novice on Rpi - I can follow clear instructions and diagnosis but useless when it comes to Linux or coding.
Any suggestions please?
E.g. Is there any other way I can connect the RPi a laptop to complete the set up? Do I need to find a screen to see the script as a it boots up?
Thanks in advance.

You don’t need a screen keyboard…
The easiest way is to plug ethernet cable on Rpi and boot. The use the android app to find volumio or use a scanner app such as ‘fing’ to find it, or maybe your router to show all devices connected.
The connect to volumio using the IP address you found.
But, with a fresh install you should see the hotspot. Search available WiFi networks around you.

Thanks for the suggestion balbuze - I can see the devices from the app connected to my eero router. I’ve added Fing as well, which confirms that the RPi is not sending out a hotspot signal, whether the Ethernet cable is connected or not.This might possibly be an issue with the RPi itself - it is new out of the box. Is there any other way I can check the normal function of the RPI itself, independently of Volumio?

You have to check WiFi networks available from WiFi settings on your smartphone. Not from Fing, as it returns devices connected on the known network.
But if you can access volumio, why don’t you configure WiFi settings to use it. Hotspot goal is to help configuration when no eth is available.

Thanks again for speedy response. I understand I am looking for a wifi hotspot from the RPi, when I start up Volumio for the first time. However this is not visible, either with or without an Ethernet cable, so I cannot access Volumio and proceed with the setup.
I have just installed Raspbian aon another SD card and managed to operate it via a VNC, following Tomshardware instructions. This involved adding a SSH file and another file my home wifi SSID/Pw details to files in the root folder of the SD card, then connecting the RPi to my laptop via an Ethernet cable and controlling it from there. Hence, I think I’ve proved the board and wifi antenna work, and that the problem likely lies with the Volumio installation software. What I did is way over my head - I just followed instructions.
Am wondering if there is something similar I can do to force Volumio to be visible?