Raspberry Pi 3

Quick one - do you guys have any idea on when the Raspberry Pi 3 will be supported?

I’m certain that it will be supported but this will only be after it is available for the dev’s.
If you get a unit and bring it to michelangelo he will make haste. :wink:

Development is focused on Volumio 2, in my opinion this should keep having the focus. But pi3 isn’t in the hands of users as of yet. And if the delivery time of the pi0 says something, it could take a while.

I just watched an interview and apparently they have a much bigger stock with the RP3 and they are able to manufacture 100’000 pi3 per week.
They apparently had such supply issues with the 0 because they did not anticipate such high demand.
But they are apparently prepared this time.

I talked with my supplier here in south east asia and they will get over 5’000 on march 11th and I already ordered 10 pieces :slight_smile:

Today I received my Raspberry Pi 3. I immediatelly tried to run Volumio1.55 but it does not seem to boot up. Was this to be expected? The Raspberry site says “Complete compatibility with Raspberry Pi 1 and 2”. They probably mean compatibility with modules and accessories…

Is there much work involved in making Volumio run on the Pi 3 ?

I’d be interested in helping out but I wouldn’t know where to start…

I did expect it not to work since every new raspberry pi board required a new image thus far.

About helping with the development, you could message michelangelo he would probably have some pointers.

I’d like to do that but as a newbie on this forum I’m not allowed to send direct messages to other users :frowning:

Hi all,

I may have a clue to help using the new RPI3.

On many other linux distributions, the booting process stucks because of the integrated wifi card.
An idea would have been to remove or disable it, but it’s not possible. :wink:
So, if you have a RPI2, install Volumio in it, and then use the card in the RPI3. It should work.

The solution was found on the OSMC forum.

I didn’t take the time to try on Volumio, because I haven’t any SDCard free… :frowning:

Hope it helps, while a true solution is found for all RPI3 distros.

and Thanks for the great job of the Volumio Team !


I’ve been running Volumio and Musicbox on Pi2B for a few weeks - in favour of Volumio. Today I got my Pi3 and it will not load either Volumio or musbox. It will not load. DON’T BUY A Pi3 if trying to use either of these music servers. And lets face it as a music sever Pi2 is all you need.

Very disappointed with the Pi3. Don’t buy it until fully supported. I’m disappointed.

Pi3 is not the same as Pi2 so it takes some work to get Volumio working. A solution is on the way in the next Volumio 2 beta release.

Hi everyone,
Just wanna let you know, that I’d be very glad to see the RP3 fully supported with wifi. Since my wifi-dongle doesn’t want to stream radios (exept 1 radiostation =/) I think it would be very nice if the RP3s Wifi would be fully supported and there is no need for anything else beside a good DAC to enjoy Volumio. Also makes it 6$ cheaper and more of a out-of-the-box solution that will appeal to more people.

finally just wanna thank you for all the good work. And I understand that it takes some time to support the RP3. I already bought one and can’t wait till you release a build for it. I love Volumio! (been using it quite some time now) =)


It appears Volumio 2 is almost ready and has been tested on the Pi3. Good news. I’m OS for a month so when I’m back it should be ready for download.

Still disappointed but now some hope.

Volumio 2 rc1 has been released. You can find the link on Volumio’s facebook. I tried it myself, but I had problems working it with my Hifiberry Digi+.

It’ll happen soon enough.

Digi+ with PI 3 doesn’'t work : i have white noise at very high level.

HiFiBerry wrote me that that release (volumio2 RC1) is still using an old kernel. It need to be update to the current kernel version.

When ?


I also have the RPi 3 & currently using Pi 2. The 2 as you know works well but I used the new Volumio v.0856 img for RPi 3 I have it up and running but the library will not load I tried so many different ways to point the directory out to the program it says success but it only shows the first address of the directory ie: My NAS but you open it and its empty, where as Pi 2 opens correctly & you can advance through & it list all. Ha gonna try the v.0861 now will post my result

Hello again Tried it still same result not loading my library

For the complete list of raspberry pi 3 accessories , you will need camera, case, heat sink etc… For Raspberry pi camera module, you can go for official camera module.

You can go for bestoninternet.com for the raspberry pi accessories.