Rasp Pi-2 with 2.224 cannot find USB drive

I had not used Volumio for a while (traveling), so I decided to update. I did the intermediary update and then update to most current (2.224). When I tried to play a song, nothing happened. I did a “Rescan” and all my songs disappeared. I have a 750 GB USB HD attached via USB to Pi. It has an independent power supply. It was working perfectly before upgrade. The drive lights up, but when I click “Rescan” the access light does not flicker and it does not appear that the drive is being read. I tried the drive on my (Linux) desktop computer and it seems fine.
I searched the database, but I guess I didn’t use good search terms as I got 998 hits, but nothing like my problem (I did not read them all ;>) If this problem has already been addressed, please point me there. Otherwise, any help greatly appreciated.
I have not done a “Factory Reset” or “Delete all user data” as it did not seem like that would help.

OK, so 25 have looked at this, but no one has any suggestions? I cannot be the only one with this problem, am I??
Any help from the developers?

Check that the USB drive is being recognised by the system. From an ssh session (or direct keyboard) type ‘lsusb’ before and after connecting the drive to your device.

I know, old thread, but still having the problem. Work around has been to use NAS, but I’d still like to use USB hdd.
Can you give me a 30 sec. tutorial on connecting via ssh? I have heard about it, but don’t know how to do it. Using keyboard and monitor would be a pain. My main box runs Linux (MX-19).

Note: I tried ssh volumio@ and get the message “connection refused by host”


You must activate ssh on the volumio side. Connect in a web browser to this address: /dev

Active ssh via the corresponding button that appears.

That worked. Thanks. I also remembered from my own post years ago that Volumio wants FAT32 formatted usb hd, so I reformatted it (was ext4) and am in the process of reloading 500+GB of music. Once that is done, I will reconnect the drive and see what happens.

Fat32? Hu, not really, or not at all, to be honest…

Fat32 is a VERY old format standard (back to the 70’s), inherited from Windows/DOS (actually it was an extension of FAT which was for 16 bits computers…) It was very easy to use and fast, specially for USB sticks of (very) small size. But for an external HDD of standard size today, this is surely not the best choice.

Actually, Volumio is based in Linux/Debian. You will get better results with USB HD formatted in native Linux formats, ie. ext2, 3 or 4. ext4 would be the best choice, in my opinion…

The only good reason for fat32, would be if you intend to plug your HD to a Windows computer in order to populate it., and if your HD is really small, like a (very) old US stick… Otherwise, it’s better to stay on ext formatted HDs. If you need to plug your HDD on Windows, use NTFS, but not fat32…

Well, I will let you know when I finish repopulating the hd after reformatting. Three years ago I when I first had this problem, I formatted a drive with ext4 which is what I normally use, Volumio could not find it. I reformatted to ntfs, still couldn’t find. Finally reformatted to FAT32 and it worked just fine. I have no explanation except it worked and the others did not. And, yes I remember FAT and DOS. I ran a medical office with 3 dumb terminals attached to a 286 PC with a 40MB hd. Without graphics (everything ASCII) it was plenty fast and I didn’t fill the hd for 2 years worth of records! How times have changed!

Yes, times are changing…

Anyway, maybe 3 years ago there were issues with USB HDDs and the underlying OS, it was really the begining of Volumio.

Actually, I gave a try to Raspify years ago, which was the ancestor of Volumio, and I’m pretty sure it was able to read ext3 HDs. Not sure about ntfs, you need ntfs3g for this, it was not installed by default in the OS, maybe.

It would be surprising that today, with a recent volumio installation, you would not be able to see an etx4 formatted HDD while you see it when formatted in fat32. I don’t see any good reason for this.

EXT4 is preferable to FAT32, mostly because it is journalized, i.e the partition table cannot be corrupted (in “standard” situations).

For some reason, my RaspPi doesn’t like my usb hd no matter how it is formatted. I was able to get ssh working and the usb hd never shows up. I plugged in another 1T hd I had and it showed up in the usb list and when I booted volumio, it showed up in the library tab. Interestingly, it did not show up in ‘Sources’ which is where I expected to find it. Is this correct?
Anyway, the ‘Music’ hd worked fine when plugged into my main Linux box, but the Pi just couldn’t find it. Not a Volumio problem.

Is it perhaps a USB power issue?
That drive might need more USB power than the R Pi can supply.

If you use a PI3, you must connect only a self powered USB HD. The power supply of the PI3 is not suitable for non powered external HDs, only the RPI4 can do this.