Rasp Pi 2 + RaspyPlay4. No more hardware volume control.

I’ve been enjoying Volumio with no issues, but today something strange happened. I was having some audio cutout issues playing some 96/24 files. I went into the MPD Configuration and changed buffer size to 4096 and Buffer Before Play to 30% figuring that might help.

It didn’t help, but what did happen is that I lost the ability to turn down the volume (set to Hardware in the Volume Mixer). I’ve since tried to put everything back, but have had no luck. I switched to software volume control and that did give me the ability to lower volume, but I don’t want that and it was working fine with Hardware control previously. I’ve rebooted, and powered off. No change. The volume up, volume down, and mute buttons do nothing. If I grab the volume control, it just springs back to 100% and does nothing.

I did find some messages on this forum that suggested editing the mpd.conf file and changing mixer_control to “Playback Digital”. My mpd.conf file is shown below. It’s already set to “Playback Digital”.

I need to be able to lower the volume since at 100% it overdrives my receiver and creates distortion. Any suggestions?


pi@volumio:/etc$ more mpd.conf

Auto generated mpd.conf file

please DO NOT edit it manually!

Use player-UI MPD config section


follow_outside_symlinks “yes”
follow_inside_symlinks “yes”
db_file “/var/lib/mpd/tag_cache”
sticker_file “/var/lib/mpd/sticker.sql”
log_file “/var/log/mpd/mpd.log”
pid_file “/var/run/mpd/pid”
music_directory “/var/lib/mpd/music”
playlist_directory “/var/lib/mpd/playlists”
state_file “/var/lib/mpd/state”
user “mpd”
bind_to_address “any”
port “6600”
zeroconf_enabled “yes”
zeroconf_name “volumio”
samplerate_converter “Best Sinc Interpolator”
volume_normalization “no”
audio_buffer_size “2048”
buffer_before_play “20%”
filesystem_charset “UTF-8”
id3v1_encoding “UTF-8”
gapless_mp3_playback “yes”
auto_update “no”
group “audio”
max_connections “20”

decoder {
plugin “ffmpeg”
enabled “yes”

input {
plugin “curl”

audio_output {

             type           "alsa"
             name           "Output"
             device         "hw:0,0"
             mixer_control  "Playback Digital"
             mixer_device   "hw:0"
             mixer_index    "0"
             dop    "no"


Sorry, no answer but I have exactly the same problem with other hardware (Raspi B + PCM5102, topic=> pcm5102-raspi-volume-issue-t2912.html ), so I put a flag here.

Thanks Kit. Did it ever work for you? Mine did. It worked fine and then it stopped.

No, I received it Saturday, tested all drivers and three versions of Volumio (1.4, 1.51, 1.55), and I ever had this issue with driver Hifiberry (the only one which provide sound in my case).

I opened a thread on Audiophonics forum, if my problem is solved in this way, I’ll give you the tip here.

I got the same problem, Rasp Pi2 + Hifiberry DAC+. It worked before but then I rebooted and since then it doesn’t work…


Same over here.

New image, set I2C to Hifibery +, Volume-control = Hardware (default), reboot…

mpd.conf says:

audio_output { type "alsa" name "Output" device "hw:0,0" mixer_control "PCM" mixer_device "hw:0" mixer_index "0" dop "no" }

PCM is not correct, because Volume-settings in GUI says “Hardware”

In GUI set “Volume controle” to “disabled”

In GUI set “Volume controle” to “Hardware”


…broken, volume jumps to 100%

mpd.conf says:

audio_output { type "alsa" name "Output" device "hw:0,0" mixer_control "Playback Digital" mixer_device "hw:0" mixer_index "0" dop "no" }

Kind regards,


Well, they told me that in “bitperfect” mod, volume is always stuck to 100%.

That doesn’t seem right. You’re using HiFiBerry DAC+, right? I’m using the RaspyPlay4. They both use the TI PCM5122 (Burr-Brown) DAC chip which supports hardware volume control. Right on the HiFiBerry page (https://www.hifiberry.com/dacplus), it says:

The spec on the TI part talks at length about how the Digital Volume Control works (see table 41 in the spec, http://www.ti.com/lit/ds/symlink/pcm5122.pdf). That’s the whole point of having hardware volume control, so the gain is handled in the chip instead of messing with the audio stream which is what software volume control would do.

I still don’t get why it worked fine and then it didn’t for me. Maybe I need to do a fresh Volumio install to see if it goes back to behaving properly.

I fixed the problem by switching to Moode Audio Player. It’s another fork of the same project (Volumio / RuneAudio). The developer seems very gung-ho about supporting and promoting it. Not sure what my long-term solution will be, but it was easy enough to switch over for the time being. Hardware volume control is working fine.

diyaudio.com/forums/pc-based … ry-pi.html

Hardware Volume control was finally working for me after finding & using the correct “simple mixer control”
“amixer” or “amixer scontents” is the command which lists the correct one, together with the present and available settings.
see also post13312.html#p13312