Qnap Nas not able to mount in config

Hi I own A Q nap TS 251 I have tried all sorts of different ways of wording the path to mount my music folder & it keeps coming up with the cifs argument no matter what I do Inclusive of the advance option work around(vers=1.0. or 2 or 3) it still will not mount any Ideas??

Send a log so we can see what error is generated please.

I have sent a log of which is here: logs.volumio.org/volumio/EMlA0du.html. Hope it helps I have the player up and running & it is connecting to my Hi Fi & I can play music but not from the mount obviously, I have the allo digi board mounted on my pi in case you need to know that & that is operational.

I can see in the log complaints about the smb version, and it doesn’t look as though you have a version set in the advanced options (although you said that you had tried this in the OP). Can you try adding the drive again, with “vers=1.0”, and then send another log?

P.S. What is the smb version set on your NAS?

I got it to work on reflash. I have been aware at times of a corrupt flash when using the pie (not just me 2 members of the family use it this way & have suffered the same issue we have learnt due to the flash software being used it sometimes claims a successful write when it is indeed not.

Well I had a dream & 3 am this morning I got up lol this going over in my head & decided to re flash the Volumio as it had been glitchy when i was able to use it Having done this I then did config & re-entered my nas it failed then re- tried using vers=1.0 This has worked & all is working as it should. Originally I was using sound@home to comunicate but now you have wifi connection I use the player direct.
Thanks for your attention on this I am most greateful your here to help good work being done here & its much appreciated.

Hi sorry to be a pain … So ok a good flash of volumio up and running (2018 version) & my nas is mounted but I have just gone through the library & hardly any of the tracks have what they are on them their track number title or artist are all blank any solution? I tried Entering in the compilation meta data the following :Track Number, Track Title, - , Artist, .file type., No luck some come through but not others. On previous volumio it was spot on but has baffled me I would have thought something would be coming up from what I wrote. this obviously not my strong point.

Well Whilst awaiting A return post for a solution I did some searching & I discovered that the bulk of my drive 1.3 TBite of music was ripped with EAC (Exact Audio Copy) this rip labels the song (Track N Title - Artist) but writes no meta data in the md page. but in foobar player it allows you to do this & that is why some have come up.
but its one hell of a task to go through to correct this so hoping there is something i have missed

No solution for you, but can I suggest that you start a new post with an appropriate title … much more likely to get a reply. Also, helpful for people in the future doing searches.