Python wget module

I try to install wget in Python, I use these commands:

$ apt-get update $ apt-get upgrade -y $ apt-get dist-upgrade -y $ apt-get install wget

but there is no way that works, the program that I run tells me that the wget module is missing.
Any ideas?


Firstly, please don’t use use ‘apt-get dist-upgrade’ or ‘apt-get upgrade’ … you are VERY likely to break your installation of Volumio.

Secondly, “install wget in python”??? … ‘wget’ is already installed on your system, it is not a part of python (although it can be called from python). (actually, trying from within python is probably what saved your system :wink:).

Thank you for your attention, my way of learning is to destroy systems !!! :smiley:
I am trying to run a small program in python that executed from ssh using $ python plays a flac file in Volumio. Very elementary everything but it worked correctly until I tried to install the new version of Volumio. It gave me a corrupt system error, I went back to factory installation and installed the new version.
When I want to run the program, python tells me that the wget module is missing, hence I try to install it.
The question would be why if it is installed I can not invoke it?

Ah, I stand corrected there is a wget python module Does the documentation for your python script not list it’s dependencies (just to make sure this is actually the python module required)?

You probably were looking for:

pip install wget

General note, it’s always a good idea to spend a few moments looking up what these commands found on general “tutorials” online do, before copying them over to your shell!

Gracias @ashthespy/@chsims1
I have been trying to develop this small program for 15 days, reading online manuals and examples. It happens that although I have programmed in VB, I never did it in Python, so I go with the test/error method.
When doing pip install wget I have this error: -bash: pip: command not found
Maybe I should go back to a clean installation and try pip install wget first before the commands I executed …

With this I worked well, thanks to all:

sudo apt-get update sudo apt-get install python-pip sudo pip install wget