Python script not working after Volumio update

Win10, PI 2B, Volumio 2.348

I replaced Volumio from an earlier version as the Update command did not operate, and now, although Volumio works, my Python script does not.
It read the current_song from MPD and put it on my PreAmp display.
In an effort to find out why I tried a command manually and it came back with the error “ImportError: No module named MPD”.
I tried to add the complete text as an attachment but the txt extension was not allowed!

Is this a version incompatibility problem?
Any suggestions welcome !!

I really think you would be better helped if you addressed the question to the author of the python mpd client/library that you are using.

P.S. you have got the client/library installed haven’t you :wink:?

Thanks for the reply. I am a novice at all this so all help is good help!

I have a service file in /etc/init.d and an executable Python script in /usr/local/bin
This is what I had and which worked in V’ 2.224

Wherever you get your help from, you really need to provide as much detail as possible. Only you know what you have installed or are trying to run :wink:. For starters you could post the service file & the script (or if it is too long, provide a link to it on pastebin or something similar).