PSU Problem: Looking for an Electrician

Hi everyone!
I’m building my own PSU for my DIY project. Because of I have a touchscreen display plugged to the Rpi, and an Allo Boss DAC to feed separately, I’m looking for 2x5v and at least 3A. So I bought this toroïdal
and this PSU . The toroïdal comes from this seller and the PSU comes from an ebay dealer in china(I can make pictures of it but it seems it’s exactly the same product).
I set the trimpots to 5V and plugged the cards on each outputs of the PSU(ground is plugged to the case) but the Rpi says there is a problem: red LED blinks when Rpi is ON(in stand-by mode red LED is fix). I tested with a multimeter, and the PSU can give 7,5A at each outputs(not tested simultaneously). Same problem when display is plugged. I also tested the toroïdal: 8V at each outputs. I tried to plug cards on the 2 outputs, I tried to plug the Rpi only: the problem persists.

Can someone help me to find an issue? I don’t understand why it doesn’t work. Do I have to set to more than 5V(I’m exactly at 5,03V)? Maybe I have a dead capacitor on the PSU?.. I’m lost :confused: :frowning:

Hi, have you measured the PSU output voltage 5V with load (= the running rpi) or in no load operation?

Yes. I’ve got 5V when in stand by and 4,93V when volumio is running. CPUs are getting hot really fast…

Hi DipterePow,

I’m not an electrician but an electronics engineer - if that is o.k. :smiley:
My first advise is: Try other / better Micro-USB Cables/Connectors.

The parts you ordered are a good choice in my opinion.

I built a very similar PSU for a very similar hardware setup (same regulator - bought in China for about 15€), but only a 25VA 2x9V(2x12,5VA) transformer from Talema (bought as a used part on Ebay for another 15€).
This is sufficient to drive a PI2 with Allo Boss and a WiFi dongle as well as an 128GB USB Stick connected to the PI on the 1st PSU channel and the official 7" PI display on the 2nd channel.
This setup is working very stable. I trimmed both regulators to output 2 x 5,1V and measure that value also while the system is running. No worries at all…

I would suggest to recheck your cables and soldering points first.
The fact that your voltage is going down to under 5V while running points to some issue with that.
If that is 100% superduper - you may be in need of having an ESR meter to check the capacitors - or/and an oscilloscope to check the DC noise on the outputs of the regulator.

Your setup should even work much better than mine, because of the better, bigger and also more suitable transformer you use - due to the fact that your regulators have to burn down about 1,5V DC less than mine - thanks to the only 8V AC instead of 9V AC and so the regulators do get a bit less hot (which is good for the life of the capacitors that are located very near to the heat sinks of this module…)

Just to know: 8V AC will give you (8V AC * 1,44 = 11,5V DC) - So - in theorie - a 7V AC (7V AC * 1.44 = 10V DC) transformer would be even better - in practise - your choice of 8V is the best :wink: ---- Also to know: In practice the LT1083 is working good if it has about 3V more on it’s input than it has to deliver on it’s output.

if you want to send me some fotos i may be able to see something more about what could be the issue.

What brand are the capacitors on your regulator board ? (Nichicon ? - or something else ?)

Again - your choice for parts seems to be the right one for that price :slight_smile:
Even a 30VA transformer should be enough - spending the money for a better regulator board like (LT3042, LT1764…)

Best Regards

1 Like

Hi Josh2000,
Thank you very much for all these percisions. That makes me feel better :smiley: :smiley:

So I think it’s a wiring problem. I use these cables:
No solering AT THE MOMENT. Just plugged to the regulator by a pair of jumper wire. I plan to connect cables to a part of proto board on some soldered connectors. It is the least worse solution I found(difficult to find great big cables with this kind of connectors(micro USB).
What did you use to connect your system?..

It is the best point of view I can get…

Thanks a lot for your help!!!

EDIT: Here is the eBay link of the regulator :
AND I just remembered that it was you who steered me to this model :laughing:

1 Like

Ok, I found new cables(Which support until 3A). I just plugged the rpi(no display, no dac…) and… Nothing happens! Volumio doesn’t launch. Green LED doesn’t blink, as if there is no SD CARD. I measured output voltage on rpi: 5V (exactly like on the regulator). I checked the fuse: 5V at each points. I flashes again the SD CARD(SanDisk 16GB class 10) and checked it with Disk Utility: everything is OK. My rpi is new so what could be the problem?..
if anyone has an idea to suggest…
Thanks in advance

1 Like

What I have noticed is that the USB socket of the Rasperry has a high contact resistance and thus a voltage drop. I use to supply the pin header.

best regards

My RPi was broken. I just receivd a new one. I built my own power câbles(I soldered an extra wire to each micro usb connections). It seems to work well. I just have a weird(?) thing: The Green LED(ACT) blinks all the time. But the led does not use all its power. It is necessary to observe well to see the blinking because it is very very low… But real and regular (almost one per second). Can anyone tell me if it is normal or not?

Ok it’s not perfect. Sometimes, not very often, the red led is blinking.

How do you do that?

Hello, I had a similar situation, and nothing helped, even a new Micro-USB cable didn’t help.

The solution is to supply the Pi by the DAC. Look at on the Allo Boss documentation. You have to use the DAC’s GPIO for ground and pins next to the USB C connector for power. Like this you can use bigger wires (for electrical assemblies) easily. A little soldering and the power supply is stable! It works very well for me!

Same, nothing helped me too. I think a 30VA transformer isn’t enough, but of course, I am not a professional and I decided to call for some electricians that fore sure will fix my problem. And the guys from really fixed it. Unfortunately, they still didn’t explain to me what was wrong, and how could I fix it by yourself, but anyway I am thankful. If you won’t manage to fix it in the foreseeable future better to contact those guys, you won’t regret it.

Better call an electrician.

1 Like