Problems with Schiit Modi 2 DAC

I have a Raspberry Pi B+ running the latest volumio 1.55 image. The RPi device has been working fine for over a year but I recently upgraded the USB DAC to a Schiit Modi 2 and there are problems. When I first hooked up the device it seemed to be recognized , there were no errors in dmesg, but trying to play any music resulted only in a blast of static through the speakers. I looked for a solution here going over some threads I tried the following solutions.

<<No Effect>>
dwc_otg.fiq_enable=1 dwc_otg.fiq_fsm_enable=1 dwc_otg.fiq_fsm_mask=0x3 (also tried masks 0x2,0x4,0x7)

<<No Effect>> (device not recognized at all)

<<No Effect>>
options snd-usb-audio nrpacks=1

I did find one thing that seems to solve the problem. Setting the USB to 1.1 speed only with

<<Worked :>>

This seems to result in normal glitch free audio. But I have not tested it with anything above 44.1/16 . I have a Wifi USB device plugged into the Pi as well and I don’t really want to reduce the USB speed if I can avoid it. Is there any other solution ? Is it possible to reduce the USB speed for only one port ? Does anybody know what E/S switch should be set to on the back of the MODI? I have it set to E (expert mode).

Thanks for any help.